Bug 7669 - provide archive/delete for monographs (including page to access them)
provide archive/delete for monographs (including page to access them)
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: General
1.1
All All
: P3 normal
Assigned To: PKP Support
: 5969 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-05 15:31 PDT by Juan Pablo Alperin
Modified: 2013-08-27 15:37 PDT (History)
7 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Juan Pablo Alperin 2012-07-05 15:31:35 PDT
Need to allow editors to archive and delete monographs that have been submitted. There is currently no grid specific for such monographs and they probably deserve their own tab to keep them out of the way of ongoing work.
Comment 1 James MacGregor 2013-03-15 13:52:16 PDT
See also bug 8167. One thing that would be great to see is an OJS-reminiscent Archive page. But basically, there should be 1) an easy way to entirely decline/delete a submission; and 2) an easy way to view declined, archived and published submissions, based on status.
Comment 2 Alec Smecher 2013-04-02 15:44:57 PDT
James, published content is already available in OMP via the Catalog Management link, and a similar approach will be ported into OJS shortly. That leaves archived (e.g. rejected) content unaccessible. Would a place e.g. on the Dashboard to access that content only be sufficient? I'd prefer that approach as it helps organize content into separate heaps rather than lumping it all together.
Comment 3 James MacGregor 2013-04-02 16:05:28 PDT
(In reply to comment #2)
> James, published content is already available in OMP via the Catalog
> Management link, and a similar approach will be ported into OJS shortly.
> That leaves archived (e.g. rejected) content unaccessible. Would a place
> e.g. on the Dashboard to access that content only be sufficient? I'd prefer
> that approach as it helps organize content into separate heaps rather than
> lumping it all together.

Alec, I think that would be perfect.
Comment 4 Michael Thessel 2013-06-24 11:01:45 PDT
I added 2 pull requests to GitHub. 

https://github.com/pkp/omp/pull/5
https://github.com/pkp/pkp-lib/pull/38

There are 2 things I want to double check and see if you are OK on how I implemented the archive:

* Can a subeditor access all archived submissions?
* Is it correct to hide declined submissions from the unassigned and assigned submissions grid?
Comment 5 Alec Smecher 2013-06-24 12:34:02 PDT
Implemented submissions archive
https://github.com/pkp/omp/commit/33d4ed2cfb47fa38fc2653f04774a78b40296b80
Comment 6 Alec Smecher 2013-06-24 12:39:50 PDT
(See additionally bug #8153 for optimizing submission lists into SQL.)
Comment 7 Alec Smecher 2013-06-24 12:50:02 PDT
Port archives to OJS master
https://github.com/pkp/ojs/commit/83b0dabb64b622925d09989afe8292ad6810c813
Comment 8 Alec Smecher 2013-06-24 12:50:51 PDT
On your specific questions:
* Can a subeditor access all archived submissions?
No, for the moment let's not give them that permission.
* Is it correct to hide declined submissions from the unassigned and assigned submissions grid?
Yes; we may also want to hide these from the author's list, but let's do some testing/review on that first.
Comment 9 Alec Smecher 2013-06-24 12:51:26 PDT
(Note to self: we need to consider the disappearance of STATUS_ARCHIVED during upgrade for the OJS port of this.)
Comment 10 Michael Thessel 2013-06-26 09:38:35 PDT
I added a pull request to prevent subeditors from viewing archived submissions. From a usability perspective it might make sense to remove the "Archived Submissions Tab" for users who cannot view them too.
Comment 11 Alec Smecher 2013-06-26 16:56:21 PDT
Sorry, Michael, I gave you bad information. Sub-editors can access the archive, but it should only contain the archived submissions that are assigned to them. But hold on before you make that change -- Jason is currently refactoring submission lists to use SQL, so you'll likely step on his toes.
Comment 12 Jason Nugent 2013-06-27 07:48:03 PDT
Hi guys -- I've committed my changes to the dashboard queue, so feel free to make the necessary logic changes you need to make, Michael.
Comment 13 Michael Thessel 2013-07-06 17:35:41 PDT
I merged the archive code into stable and submitted a pull request here: https://github.com/pkp/omp/pull/6. The archive works in stable now too. 

The only thing left is to implement the new SQL queue logic Jason has been working on. Do you need this in master and stable?
Comment 14 Michael Thessel 2013-07-09 12:39:25 PDT
Ok, looks like Jason already implemented the logic change in https://github.com/pkp/pkp-lib/commit/5576b224593c2bde4ffc9087c1ae3302e8d50143. I think this is complete now.
Comment 15 Alec Smecher 2013-07-09 12:41:29 PDT
Thanks for checking, Michael. I'll re-open this if I run into any trouble with the 1.0 back-port.
Comment 17 Alec Smecher 2013-08-27 15:37:15 PDT
*** Bug 5969 has been marked as a duplicate of this bug. ***