We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 7283 - Grid checkboxes need some sort of information/explanation dialogue
Grid checkboxes need some sort of information/explanation dialogue
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: User Interface
0.8.1 Internal Testing 1
All All
: P3 normal
Assigned To: PKP Support
: 7288 7335 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-03 10:30 PDT by James MacGregor
Modified: 2012-04-26 02:41 PDT (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2012-04-03 10:30:27 PDT
See, for example, the Reviewers grid on a Submission's Internal Review stage page. There's a checkbox there, but I have no idea what it does. I suspect that checking it may "complete" the review, but I'd rather not do that if I can't back out of it. 

Scheduled against .8.1; feel free to bump if need be.
Comment 1 beghelli 2012-04-13 11:20:47 PDT
*** Bug 7288 has been marked as a duplicate of this bug. ***
Comment 2 beghelli 2012-04-13 14:51:44 PDT
*** Bug 7335 has been marked as a duplicate of this bug. ***
Comment 3 beghelli 2012-04-19 02:54:02 PDT
My suggestion is to add a text (a verb), just like all the other link actions. We can still have the icon, but with the proper text next to it. It will make much clearer what does that action and it's the easiest way to do this.
Comment 4 Jason Nugent 2012-04-24 07:29:36 PDT
Hey guys,

How do you feel about using the hoverTitle parameter that is currently available for link actions to have some text displayed when you mouse over the grid checkbox?  We don't currently use it for anything.  Technically, there is text in the grid cell now, but we use CSS to align it off of the page so you can't see it.  

Another alternative is to create a div element with a small grid legend describing what each checkbox looks like and what it means.  We can just include it on pages with grids.

Jason
Comment 5 Alec Smecher 2012-04-24 09:12:19 PDT
I like the hover text. We tried to avoid the use of legends etc. because they clutter up the display, and that's one of the key things we were trying to avoid in the editorial interface. Editors are trainable (i.e. they'll work with the system for a long time) and once they've learned the iconography the legend will be dead weight.

In any case, there should be some indication both of what the current state is, and what clicking it will do.
Comment 6 Jason Nugent 2012-04-24 11:40:02 PDT
Add hovering titles to grid checkbox status cells
https://github.com/pkp/omp/commit/e6b2f0576c3b71a221c62d3fe804a5070a54e76f
Comment 7 Jason Nugent 2012-04-24 11:40:02 PDT
Add grid status titles to common locale
https://github.com/pkp/pkp-lib/commit/de4d4daf79290a2bac1eb991849ceb49e6fc607b
Comment 8 beghelli 2012-04-24 14:56:04 PDT
Sorry for my late reply, but we were avoiding to use hover effects because of mobile devices. 

We can use Jason's solution, that works pretty well on devices with mouse, but maybe we can try to build a place for help on grids. It could be used for a lot of things, including description that we don't want to insert on the main page but that we think that can help users to interact with the component. 

I don't know if we call it help or info, but it could be a little interrogation icon with the "help" or "info" text next to it. It can be placed on top right (inside the blue component wrapper). When clicked, it should open a small div that reveals the help content.

For the icons case, I think that we can add an action inside the helper div that is shown with the text "show icons label", or something like that. If clicked, it shows in place what each icon means.

I don't think that this should be done right now, but it should be a concern for future releases because of the importance of mobile devices.
Comment 9 Jason Nugent 2012-04-25 03:36:16 PDT
Hi Bruno,

This may be quite simple to solve, if we add the 'help' icon you are describing.  The text for the grid task is already in the cell, but the a.task CSS class applies a "text-indent: -1500px;" style to it.  If you disable that CSS attribute, the text appears above the icon.  Perhaps all that is necessary is a help icon that does this?

Cheers,
Jason
Comment 10 beghelli 2012-04-26 02:41:51 PDT
Hi Jason,

Well, it's quite simple but if we want to do it right it will take us some time, I think. Because we might want to use the help to do more than just showing labels that are already on grid. We might use it to show help content in a div, for example. So I think it's better to build something that's prepared to handle with that, or at least that's flexible enough to be extended. Because of this I think that we can use our current grid feature structure to add a help feature to our components.

Actually the grid features php implementation is missing, so we cannot avoid coupling features php code to our base components code, and that's a bad thing. I did that for ordering just because it was a must have for external testing and because the php features implementation would take an extra time that I didn't had.

But if we are going to use again the features structure, I think that we first need to finish it well. We might use it again for sorting and paging, so it's not time wasted. I just don't know if it's time to do it now.