Bug 7229 - PaymentManager error log
PaymentManager error log
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Open Journal Systems
2.3.7
All All
: P3 normal
Assigned To: PKP Support
: 7713 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-22 03:07 PDT by ntorres
Modified: 2012-07-23 11:52 PDT (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.7 (460 bytes, patch)
2012-03-23 10:34 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ntorres 2012-03-22 03:07:02 PDT
I installed 2.3.7 version and this error appears in the error log file

 ojs2 has produced an error\n  Message: WARNING: Missing argument 1 for PaymentManager::PaymentManager(), called in /ojs-2.3.7/classes/payment/ojs/OJSPaymentManager.inc.php on line 35 and defined\n  In file: /ojs-2.3.7/lib/pkp/classes/payment/PaymentManager.inc.php\n  At line: 22\n  Stacktrace: \n  Server info:\n   OS: Linux\n   PHP Version: 5.1.6\n   Apache Version: Apache/2.2.3 (CentOS)\n   DB Driver: mysql\n   DB server version: 5.0.77
Comment 1 Alec Smecher 2012-03-22 08:25:24 PDT
This error is cosmetic, i.e. everything should work fine even though you're encountering it. However, the linked patch should correct it. Thanks for reporting.
Comment 3 Alec Smecher 2012-03-23 10:34:55 PDT
Created attachment 3728 [details]
Patch against OJS 2.3.7
Comment 4 Alec Smecher 2012-07-23 11:52:35 PDT
*** Bug 7713 has been marked as a duplicate of this bug. ***