Bug 7227 - TinyMCE and Firefox 11 incompatibility issues
TinyMCE and Firefox 11 incompatibility issues
Status: RESOLVED WONTFIX
Product: OJS
Classification: Unclassified
Component: Plug-ins
2.3.8
All All
: P3 normal
Assigned To: James MacGregor
: 7228 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-03-20 14:15 PDT by James MacGregor
Modified: 2012-06-07 12:30 PDT (History)
6 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Gzipped patch against ojs-stable-2_3 (463.19 KB, application/x-tar)
2012-03-20 22:41 PDT, James MacGregor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2012-03-20 14:15:04 PDT
It appears that our current version(s) of TinyMCE don't work well with Firefox 11. See http://www.tinymce.com/forum/viewtopic.php?id=28400 for a thread on the issue on the TinyMCE forum. 

Problem: if a page has multiple TinyMCE fields, only one appears properly. The others don't appear, although any previously-entered HTML field text is still there (and can be seen and edited if the "HTML" button is clicked).

Solution: upgrade to a more recent version of the tinyMCE plugin from http://www.tinymce.com/download/download.php. 

TinyMCE currently resides in /lib/pkp/lib/scripts/. Simply replacing that code with the most recent version of TinyMCE isn't entirely sufficient, as we use a third-party image uploader plugin that has to be accounted for. 

I'm currently testing TinyMCE version 3.5b for inclusion in stable and master and will provide a patch shortly.
Comment 1 James MacGregor 2012-03-20 21:45:04 PDT
*** Bug 7228 has been marked as a duplicate of this bug. ***
Comment 2 James MacGregor 2012-03-20 22:41:33 PDT
Created attachment 3725 [details]
Gzipped patch against ojs-stable-2_3

This compressed patch can be applied to/in /lib/pkp. A few notes:

-- This patch is against lib/pkp branch ojs-stable-2_3. It should apply fine to OJS 2.3.7 (apply to lib/pkp/ directory). You may have to update some images manually; I'll try and get a compressed version of this plugin online shortly. 

-- This update includes TinyMCE 3.4.9 and Compressor 2.0.4 PHP. Turns out the "b" in "3.5b2" does stand for beta, so I opted for the other production release. 

-- Also includes the recently-included jbimages plugin. 

-- I've tested these versions against OJS 2.3.7 and 2.4 (ie. stable and master) with Firefox 11, and all seems well: all TinyMCE fields appear, and I double-checked that jbimages continues to work. 

I'd like to perform a few more tests before committing this, though. Any feedback appreciated.
Comment 3 James MacGregor 2012-03-21 12:04:02 PDT
A tar file of the updated /lib/pkp/lib/tinymce/ directory can be downloaded from here: http://pkp.sfu.ca/files/tinymce_update.tar.gz. 

This update should work fine for OJS 2.3.7, OCS 2.3.4, OHS 2.3.2, and the master branches of each. OJS 2.3.6/OCS 2.3.3/OHS 2.3.1 and below should either upgrade first or apply the fixes listed in Bug 7207, otherwise the jbimages plugin will not work. 

To apply: 
1) back up your OJS install directory;
2) download tinymce_update.tar.gz, listed above;
3) delete the lib/pkp/lib/tinymce directory in your OJS install;
4) decompress and move all contents of tinymce_update.tar.gz to lib/pkp/lib/, so that you now have a new lib/pkp/lib/tinymce directory;
5) clear your browser cache, test that multiple tinymce fields are appearing as they should, and test that tinymce image uploading is also working properly.
Comment 4 Alex Garnett 2012-03-22 13:08:53 PDT
Looks like this breaks the CMA setup too -- unable to change settings for a given Parser/Connector service or remove them once they've been added. Broken in Chrome, FF, Opera.
Comment 5 Alex Garnett 2012-03-22 13:12:57 PDT
Dropping in an updated TinyMCE lib appears not to work here. Any other changes to grid rendering that would've affected this? Seems like it might be a different bug after all.
Comment 6 James MacGregor 2012-03-22 14:11:47 PDT
(In reply to comment #5)
> Dropping in an updated TinyMCE lib appears not to work here. Any other changes
> to grid rendering that would've affected this? Seems like it might be a
> different bug after all.

Hi Alex, 

The CMA setup fields don't use TinyMCE at all -- that's all grid stuff. And I can't seem to replicate this, regardless (on ojs-stable at least). Perhaps try a fresh checkout, and open in a new bug if you continue to see the problem?
Comment 7 paul.warren 2012-03-22 14:21:13 PDT
I followed the procedure under comment 3, and the text is now showing in the text boxes. But now the graphics providing buttons for editing etc are now not showing.  Instead I get a red cross and "upload an image" message. I have checked read/write permissions on the relevant files on the server. The properties for that object indicate that the page is looking for something in a path that includes /git before /ojs etc. I don't have a /git directory on my site - is this the problem, or does /git stand for something else (e.g. alias to the public_html)?
I'm using OJS 2.3.7
Comment 8 Jason Nugent 2012-03-22 14:31:52 PDT
Hi Paul (and others reading),

There is a bundled file in the jscripts/ directory that should be deleted.  It is called '3a20bc12e08039d595aa7823d88a0a3a.gz'.  It's a compressed archive that gets created as a cache in some cases, and you can safely remove it. Doing so will solve the issue.  

Regards,
Jason
Comment 9 paul.warren 2012-03-22 14:40:10 PDT
(In reply to comment #8)
> Hi Paul (and others reading),
> 
> There is a bundled file in the jscripts/ directory that should be deleted.  It
> is called '3a20bc12e08039d595aa7823d88a0a3a.gz'.  It's a compressed archive
> that gets created as a cache in some cases, and you can safely remove it. Doing
> so will solve the issue.  
> 
> Regards,
> Jason

Thank you Jason  - I can confirm that this fixed that problem

Paul
Comment 10 Matthew Crider 2012-04-24 17:02:56 PDT
Hi all, FYI, Firefox 12 Fixes this issue.
Comment 11 Matthew Crider 2012-06-07 11:39:42 PDT
Can we close this now that firefox fixed the problem, or is this a good time to upgrade TinyMCE anyway?  3.5 is out of beta (actually they are at 3.5.2) and there looks like there are a good number of fixes.
Comment 12 Alec Smecher 2012-06-07 12:30:36 PDT
James, I'm content to direct people to update their browsers for this one; it hit a lot of other apps too.