Bug 7025 - Call to undefined method PublishedArticle::getDateModified() in atom.tpl
Call to undefined method PublishedArticle::getDateModified() in atom.tpl
Status: RESOLVED DUPLICATE of bug 6729
Product: OJS
Classification: Unclassified
Component: Plug-ins
2.3.7
All All
: P3 normal
Assigned To: James MacGregor
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-16 12:22 PST by Charles Parker
Modified: 2012-03-12 10:44 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Charles Parker 2012-01-16 12:22:55 PST
PHP Fatal error:
Call to undefined method PublishedArticle::getDateModified()
in cache/t_compile/%%83^834^8342F6E1%%atom.tpl.php on line 24


plugins/generic/webFeed/templates/atom.tpl
lines 17-25:

{* Figure out feed updated date *}
{assign var=latestDate value=$issue->getDatePublished()}
{foreach name=sections from=$publishedArticles item=section}
  {foreach from=$section.articles item=article}
    {if $article->getDateModified() > $latestDate}
      {assign var=latestDate value=$article->getDateModified()}
    {/if}
  {/foreach}
{/foreach}


PublishedArticle::getDateModified() is not a function.

The closest thing I see is on the parent object:
Submission::getDateStatusModified()
Comment 1 Alec Smecher 2012-01-17 06:06:10 PST
James, this is related to the Google Scholar metadata changes.
Comment 2 James MacGregor 2012-03-12 10:44:23 PDT

*** This bug has been marked as a duplicate of bug 6729 ***