Bug 6971 - Implement overview dashboard
Implement overview dashboard
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: General
0.8.2 Internal Testing 2
All All
: P3 normal
Assigned To: beghelli
: 6062 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-08 11:16 PST by Alec Smecher
Modified: 2012-04-23 13:03 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2011-12-08 11:16:49 PST
There's currently a placeholder on the Dashboard's "Overview" tab. Implement the functionality described there or defer to a follow-up release and remove the placeholder. (See bug #6969 re: announcement administration.)
Comment 1 Alec Smecher 2011-12-12 09:38:23 PST
*** Bug 6062 has been marked as a duplicate of this bug. ***
Comment 2 beghelli 2012-01-13 18:10:02 PST
Introduced announcement grid handler column locale key
https://github.com/pkp/pkp-lib/commit/1a55818869e0422349d3f1d133977847903c9684
Comment 3 beghelli 2012-01-13 18:10:02 PST
Introduced announcement grid handler
https://github.com/pkp/omp/commit/77964cde0186c75fdc77e33485fa39ffc1533c61
Comment 4 beghelli 2012-01-14 05:50:02 PST
Set no items text in announcements grid
https://github.com/pkp/omp/commit/967f59e62fbc3e4b593ffbe141ec17df978f9d53
Comment 5 beghelli 2012-01-16 14:30:02 PST
Removed quotation mark from fields values
https://github.com/pkp/omp/commit/82efb6230625ce6164add71226e084eed955482e
Comment 6 Alec Smecher 2012-02-09 09:42:48 PST
Bruno, is this ready to be closed? I've reviewed the commits already.
Comment 7 beghelli 2012-03-05 04:07:36 PST
Alec, the spec for this tab has a grid task due soon, and I am waiting more specs on this. The problem is that actually we have a due date only for review assignments. Juan already sent questions to John related to this, but I am not sure what was the last decision: create or not create this grid?
Comment 8 beghelli 2012-04-18 03:56:00 PDT
The task due soon grid would demand a lot of more work to be done, so we've decided to remove the overview tab for now. The announcements will stay in press home page.
Comment 9 beghelli 2012-04-18 04:20:03 PDT
Removed overview tab from dashboard
https://github.com/pkp/omp/commit/35d5907017240b9e75c7b9e216d0c5359773eb18
Comment 10 beghelli 2012-04-23 13:03:33 PDT
Closing this for now.