Bug 6946 - PDF view count issues
PDF view count issues
Status: RESOLVED INVALID
Product: OJS
Classification: Unclassified
Component: User Interface
2.4.2
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-07 14:10 PST by James MacGregor
Modified: 2012-12-18 14:47 PST (History)
3 users (show)

See Also:
Version Reported In:
Also Affects: OCS 2.3.5


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-11-07 14:10:55 PST
(Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=8039&p=31228#p31228, and replicated as described below)

This only seems to happen in Firefox. Each time I click the "Fullscreen" or "Fullscreen Off" buttons while viewing a PDF, the article_galley.view count is incremented by one. As Ute points out, this shouldn't be happening, as this is essentially just a view change, not a whole new article view. 

WRT the above problem: there must be a difference in how the PDF is called between FF and non-FF browsers. In templates/article/article.tpl, there's a good chunk of Javascript that calls the PDF in different ways given different environments, but I'm not particularly familiar with Javascript, and I'm not quite sure whether the problem is in there, or elsewhere. 

NB: The "Download PDF" option also increments the view count by 1, but I consider this correct behaviour -- this action is essentially creating a new version of the file that will be viewed separately.
Comment 1 Alec Smecher 2012-12-18 14:47:47 PST
James, this is a PDFObject quirk, not our bug; I'd suggest following up with them (or directing Ute to do the same).