We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6892 - Add search by ID option to article search function
Add search by ID option to article search function
Status: RESOLVED DUPLICATE of bug 6407
Product: OJS
Classification: Unclassified
Component: Editors
2.3.x
All All
: P3 enhancement
Assigned To: Joseph Daddario
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-09-18 19:13 PDT by James MacGregor
Modified: 2011-10-14 09:37 PDT (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
diff file including tentative solution with new field for locating a single article by id (4.25 KB, text/plain)
2011-10-10 11:11 PDT, Joseph Daddario
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-09-18 19:13:51 PDT
(see http://pkp.sfu.ca/support/forum/viewtopic.php?f=9&t=7672&p=30703#p30703)

Currently, Editors can search their various queues for eg. submission title, author name, etc. It would also be useful to search by submission ID.
Comment 1 Joseph Daddario 2011-10-10 11:11:21 PDT
Created attachment 3656 [details]
diff file including tentative solution with new field for locating a single article by id

would a patch file be preferred?
Comment 2 Joseph Daddario 2011-10-10 11:13:37 PDT
Now that I've read James' original comment it seems like the intention was to add this option to the drop down. ...will wait for review before working in this direction.
Comment 3 Alec Smecher 2011-10-11 11:56:13 PDT
Yes, it should be placed in the drop-down and coded along the lines of the other options there. Beware of hard-coding English text into the templates -- everything should be localized through the .xml files (e.g. locale/en_US/locale.xml), so that the system can be translated.
Comment 4 Joseph Daddario 2011-10-13 11:27:47 PDT
A closer look at sql used to return search results has revealed the option to locate an article by ID is already available in the dropdown as "Submission ID" -- is this correct?
Comment 5 Alec Smecher 2011-10-14 09:37:51 PDT
Ha! Sure enough, it's already filed and implemented -- bug #6407. The user who requested this must've been using something older than OJS 2.3.5.

*** This bug has been marked as a duplicate of bug 6407 ***