Bug 6719 - Issue ToC sorting options broken
Issue ToC sorting options broken
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: User Interface
2.3.6
All All
: P3 normal
Assigned To: Michael Felczak
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-06-24 10:41 PDT by James MacGregor
Modified: 2011-06-28 10:24 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.5 (1.55 KB, patch)
2011-06-28 10:22 PDT, Michael Felczak
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-06-24 10:41:05 PDT
Both the up/down arrow and drag and drop sorting options available to an Editor on an issue's Table of Contents page (http://git/ojs/index.php/test/editor/issueToc/6) appear to be broken. 

Drag and drop: I can move article items around, but they revert to their original positions after I save the page. 

Up/down arrows: clicking *some* of these (for example, the uppermost down arrow) redirects to the Editor's User Home page. 

Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=7644&p=29630#p29630.
Comment 1 Michael Felczak 2011-06-25 09:20:29 PDT
James, I can't reproduce this on a fresh stable install. Can you please describe your setup in more detail? Is this an upgraded or clean install?
Comment 2 Michael Felczak 2011-06-28 10:22:30 PDT
Created attachment 3580 [details]
Patch against OJS 2.3.5
Comment 4 Michael Felczak 2011-06-28 10:24:39 PDT
Fixed.