We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6613 - Add option to delete supplementary file
Add option to delete supplementary file
Status: RESOLVED DUPLICATE of bug 6740
Product: OJS
Classification: Unclassified
Component: Submissions and Publishing
2.4.0
All All
: P3 normal
Assigned To: James MacGregor
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-22 17:22 PDT by James MacGregor
Modified: 2012-08-27 21:37 PDT (History)
3 users (show)

See Also:
Version Reported In:
Also Affects: OCS 2.3.4


Attachments
adds a "delete" option to a submission summary (2.00 KB, patch)
2011-06-06 22:36 PDT, Mike Kamermans
Details | Diff
updated patch (2.00 KB, application/octet-stream)
2011-06-07 09:32 PDT, Mike Kamermans
Details

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-04-22 17:22:17 PDT
Currently, supplementary files can be deleted from submission Editing -> Layout Editing. There should also be an option to delete individual supplementary files from the submission summary page as well, as there is supplementary file information there (both add and edit functions) and it is not immediately clear that the delete function exists, but on a separate page.
Comment 1 Mike Kamermans 2011-06-06 22:28:15 PDT
The more I'm looking at where exactly the template for the submission summary is (it is remarkably well-hidden), the more I get the feeling that the problem may not so much be that there isn't a "delete" option in the summary page, but that there are "edit" and "add" options that are better left off - usually a summary is associated with "this is the information as it is known", and then for editing the actual properties you'd use whichever option points to editing. Of course I can still add in the "delete" option if that's the preferred solution.
Comment 2 Mike Kamermans 2011-06-06 22:36:39 PDT
Created attachment 3537 [details]
adds a "delete" option to a submission summary

This is a patch for the templates/sectionEditor/submission/management.tpl file (which may need renaming at some point, since it's the summary page. The summary.tpl file is actually the template for the summary section on the "EDITING" page), adding a "delete" operation to the already existing "edit" and "add" for supplementary files.
Comment 3 Alec Smecher 2011-06-07 09:28:47 PDT
Looks like there's still some indentation weirdness in the patch.
Comment 4 Mike Kamermans 2011-06-07 09:32:58 PDT
Created attachment 3542 [details]
updated patch

removed superfluous tabs
Comment 5 James MacGregor 2011-06-07 09:59:30 PDT
Hi Mike, I tested the patch and it looks good. I do still think that adding a "delete" option on the summary page makes sense. Eventually, it would be worth looking at allowing supplementary files to exist in the system without necessarily being automatically made available via the RT on an individual basis (it is currently possible to disable links supplementary file across the board in the RT), but that's another bug report.
Comment 6 James MacGregor 2012-08-27 21:37:59 PDT

*** This bug has been marked as a duplicate of bug 6740 ***