Bug 6563 - "User Home" link should redirect when Journal Redirect is turned on
"User Home" link should redirect when Journal Redirect is turned on
Status: RESOLVED DUPLICATE of bug 2280
Product: OJS
Classification: Unclassified
Component: User Interface
2.3.5
All All
: P3 minor
Assigned To: Michael Felczak
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-04-01 20:58 PDT by James MacGregor
Modified: 2011-04-27 12:18 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Change userHome link to go to current journal's user page (764 bytes, patch)
2011-04-19 14:15 PDT, Peter Dietz
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-04-01 20:58:11 PDT
Currently, if the Site Admin sets the Journal Redirect option to a single journal (in Site Admin -> Site Settings), non-authenticated users are still brought to eg. http://git/ojs/index.php/index/user when clicking "User Home". They should be brought to the journal-specific User Home, eg. http://git/ojs/index.php/test/user.
Comment 1 Peter Dietz 2011-04-19 14:15:13 PDT
Created attachment 3495 [details]
Change userHome link to go to current journal's user page

We have multiple journals on our instance (2.3.x), once the authenticated user clicks userHome from a journal it takes them to the index/user page, which is not where they want to go. The user would likely be expecting to go to the userHome for the current journal, which is what my local modification does. If they started from the index, and clicked userHome, then they go to index/user.
Comment 2 Michael Felczak 2011-04-27 12:18:48 PDT
Please see the discussion at Bug 2280.

*** This bug has been marked as a duplicate of bug 2280 ***