We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6557 - Submission History log locale keys untranslated
Submission History log locale keys untranslated
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Localization
2.3.5
All All
: P3 normal
Assigned To: PKP Support
: 6607 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-30 11:26 PDT by James MacGregor
Modified: 2011-04-19 09:02 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS pre-2.3.5 (595 bytes, patch)
2011-04-15 10:27 PDT, Alec Smecher
Details | Diff
Patch against OJS pre-2.3.5 (598 bytes, patch)
2011-04-19 09:01 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-03-30 11:26:02 PDT
I'm seeing some untranslated locale keys in the interface for the following page: 

http://git/ojs/index.php/test/editor/submissionHistory/3

eg.: ##log.copyedit.copyeditFileSet##, #log.review.resubmit##, ##log.editor.restored##, probably more. These keys are actually in locale/en_US/locale.xml, so there must be something going on code-wise that is preventing them from being displayed.
Comment 1 Alec Smecher 2011-03-30 11:30:39 PDT
Logging was rewritten post-2.3.x -- depending when those entries were inserted, they might be stored in different ways. Could you try to locate those entries in event_log (by assoc_id = 3)?
Comment 2 James MacGregor 2011-03-31 10:53:22 PDT
(In reply to comment #1)
> Logging was rewritten post-2.3.x -- depending when those entries were inserted,
> they might be stored in different ways. Could you try to locate those entries
> in event_log (by assoc_id = 3)?

Hi Alec, there's no event log in article_event_log with assoc_id = 3 in my local install; I can check a larger install if you think it's worthwhile. However, there are definitely untranslated log entries in that table. I'll send you a dump of it separately.
Comment 3 Alec Smecher 2011-03-31 10:56:08 PDT
James, check event_log rather than article_event_log.
Comment 4 Alec Smecher 2011-04-04 14:13:35 PDT
Sorry, James, my mistake. Could you check article_event_log with article_id = 3?
Comment 5 James MacGregor 2011-04-07 11:32:34 PDT
(In reply to comment #4)
> Sorry, James, my mistake. Could you check article_event_log with article_id =
> 3?

Hi Alec, there are a number of untranslated keys stored in the message column of article_event_log for article_id = 3. They appear like "##log.review.resubmit##", "##log.copyedit.copyeditFileSet##", etc. Not every key for that article is untranslated -- it just appears to be certain keys. These keys aren't translated for other articles, either. 

The ones I'm seeing so far: 

##log.review.resubmit##
##log.copyedit.copyeditFileSet##
##log.review.reviewerAssigned##
##log.review.reviewAcceptedByProxy##

There may be others; my local install doesn't currently have a robust set of log files.
Comment 6 Alec Smecher 2011-04-15 10:27:28 PDT
Created attachment 3486 [details]
Patch against OJS pre-2.3.5
Comment 7 Alec Smecher 2011-04-15 10:28:07 PDT
The patch won't correct existing entries. Not req'd in GIT HEAD because of the logging overhaul already committed there.
Comment 8 Alec Smecher 2011-04-19 09:01:34 PDT
Created attachment 3494 [details]
Patch against OJS pre-2.3.5

Corrected function name
Comment 9 Alec Smecher 2011-04-19 09:02:13 PDT
*** Bug 6607 has been marked as a duplicate of this bug. ***