We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6531 - "EDITOR NOTE" text hard-coded instead of actual note fetch
"EDITOR NOTE" text hard-coded instead of actual note fetch
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: General
1.1.1
All All
: P3 normal
Assigned To: Alec Smecher
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-22 16:17 PDT by Alec Smecher
Modified: 2014-09-04 07:13 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2011-03-22 16:17:57 PDT
"EDITOR NOTE" text hard-coded instead of actual note fetch.
See fixme in code marked against this entry (ReviewerReviewStep1Form).
Comment 1 Juan Pablo Alperin 2011-07-11 23:10:32 PDT

*** This bug has been marked as a duplicate of bug 6747 ***
Comment 2 Alec Smecher 2014-08-26 15:48:59 PDT
This hasn't actually been fixed -- re-opening.
Comment 3 Jason Nugent 2014-09-02 07:25:16 PDT
Alec, the line in the form class:

$templateMgr->assign('reviewerRequest', __('reviewer.step1.requestBoilerplate', $reviewerRequestParams));

Assigns parameters to that locale key, but the locale key does not actually use them.  We can probably just delete the entire $reviewRequestParams array creation on the line above and close the bug, unless I am missing something obvious.
Comment 4 Alec Smecher 2014-09-02 15:57:07 PDT
I haven't ever seen that stuff get used in the interface, so I suspect you're right.
Comment 5 Alec Smecher 2014-09-03 05:52:03 PDT
Pull request opened (not merged):
remove unused locale key parameters
https://github.com/pkp/pkp-lib/pull/159
Comment 6 Jason Nugent 2014-09-03 05:52:30 PDT
Assigning for quick review, Alec.  I'll merge into stable afterwards.
Comment 7 Jason Nugent 2014-09-04 07:11:03 PDT
remove unused locale key parameters
https://github.com/pkp/pkp-lib/commit/7d09e215516a0fa41fe1ec456cddf578ed9a9cc2
Comment 8 Alec Smecher 2014-09-04 07:11:03 PDT
Pull request closed (merged):
remove unused locale key parameters
https://github.com/pkp/pkp-lib/pull/159
Comment 9 Jason Nugent 2014-09-04 07:13:03 PDT
remove unused locale key parameters
https://github.com/pkp/pkp-lib/commit/d90bce1ede57086ed25c3c065c74f0bdc0ed06af