Bug 6519 - When upgrading from installation with wrong language code of Swedish to correct language code, how to update?
When upgrading from installation with wrong language code of Swedish to corre...
Status: RESOLVED INVALID
Product: OJS
Classification: Unclassified
Component: Localization
2.3.4
PC Linux
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-18 01:32 PDT by Maria
Modified: 2011-03-18 08:50 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Maria 2011-03-18 01:32:03 PDT
I have upgraded a copy of our installation, to eventually upgrade the public one.

The database is full of "sv_SV", but the new code is "sv_SE". Are there any tips on how to update this, so that it becomes correct in the updated version?

Related to bug 4802.
Comment 1 Alec Smecher 2011-03-18 08:50:51 PDT
Hi Maria,

The best way to do this is probably to generate a database dump using mysqldump, then perform a search and replace, looking for 'sv_SV', and replacing it with 'sv_SE'. Then reload the database from the dump file.

I'd suggest doing this on a test copy of your installation before you run it on the production DB.

Since this is an administration question, not a bug, the best place to post it is on the support forum at http://pkp.sfu.ca/support/forum rather than here.