Bug 6510 - ROLE_ID_PRESS_MANAGER referenced in PKP library
ROLE_ID_PRESS_MANAGER referenced in PKP library
Status: RESOLVED FIXED
Product: PKP-LIB
Classification: Unclassified
Component: General
Undetermined
All All
: P3 normal
Assigned To: PKP Support
: 6513 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-17 08:38 PDT by Alec Smecher
Modified: 2011-03-18 08:53 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS pre-2.3.5 (Work-around only) (811 bytes, patch)
2011-03-17 08:40 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2011-03-17 08:38:19 PDT
ROLE_ID_PRESS_MANAGER referenced in PKP library
Comment 1 Alec Smecher 2011-03-17 08:40:05 PDT
Created attachment 3467 [details]
Patch against OJS pre-2.3.5 (Work-around only)

Temporary fix for OJS 2.3.4ish.
Comment 2 Alec Smecher 2011-03-17 18:52:22 PDT
*** Bug 6513 has been marked as a duplicate of this bug. ***
Comment 3 Alec Smecher 2011-03-17 18:52:45 PDT
See bug #6513.
Comment 4 jerico 2011-03-17 21:29:04 PDT
Alec, thanks for migrating this to OJS. I'd completely forgotten that all apps are using policies for this handler... I remember now that this was an issue before. I'm always confused because we have a name clash for the announcement handlers in the app.

Did you introduce the same into OCS/OHS or should I do that?
Comment 5 Alec Smecher 2011-03-18 08:53:04 PDT
None of the current stable releases of OHS or OMP have this bug AFAIK, so no need to worry about them. Only ojs-stable-2_3 contained a version of the PKP library with this bug.