We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6480 - Check getDatePublished usage and nullability
Check getDatePublished usage and nullability
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: General
2.3.5
All All
: P3 normal
Assigned To: PKP Support
: 6452 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-08 08:32 PST by Alec Smecher
Modified: 2011-03-21 09:32 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.4 (39.50 KB, patch)
2011-03-08 08:39 PST, Alec Smecher
Details | Diff
Additional patch against OJS pre-2.3.5 (997 bytes, patch)
2011-03-21 09:32 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2011-03-08 08:32:12 PST
Check getDatePublished usage and nullability for both issues and published_articles. Both should be nullable and code should not assume either is available. See bug #4718 for changes to make a tool available to modify article publication dates.
Comment 1 Alec Smecher 2011-03-08 08:39:17 PST
Created attachment 3448 [details]
Patch against OJS 2.3.4
Comment 2 Alec Smecher 2011-03-08 09:56:13 PST
*** Bug 6452 has been marked as a duplicate of this bug. ***
Comment 3 Alec Smecher 2011-03-08 15:37:39 PST
(Committed to ojs-stable-2_3)
Comment 4 Alec Smecher 2011-03-21 09:32:40 PDT
Created attachment 3469 [details]
Additional patch against OJS pre-2.3.5