Bug 6452 - Display Issue Data's Year value for citation_date
Display Issue Data's Year value for citation_date
Status: RESOLVED DUPLICATE of bug 6480
Product: OJS
Classification: Unclassified
Component: Submissions and Publishing
2.3.5
All All
: P3 normal
Assigned To: PKP Support
Depends on: 6428 6451
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-27 18:54 PST by James MacGregor
Modified: 2011-03-08 09:56 PST (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-02-27 18:54:31 PST
If an article's citation_date value is empty, check to see if the Editor has supplied a value for the Issue Data's Year. If so, display that as the citation_date via the GS metadata template. Example code from Alec: 

{if $article->getDatePublished()}
    <meta ... value="{$article->getDatePublished()}"/>
{elseif $issue->getYear()}
    <meta ... value="{$issue->getYear()}"/>
{/if}
Comment 1 Alec Smecher 2011-03-08 09:56:13 PST

*** This bug has been marked as a duplicate of bug 6480 ***