Bug 6443 - Correct plupload/jquery.validate localization loading problems
Correct plupload/jquery.validate localization loading problems
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: General
To Be Determined
PC Linux
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 11:50 PST by jerico
Modified: 2014-03-31 10:39 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerico 2011-02-24 11:50:44 PST
Both plupload and jquery.validate do not have all languages that we support. We can create a single template file replacing the original JS files and including that as JS. The file replaces literal strings with {translate} tags. We can then move all translations to our locale files and add as many languages as we like without additional maintenance cost on the coding side.
Comment 1 Alec Smecher 2014-03-27 17:08:11 PDT
Changed the title to describe the problem rather than the solution.

The problem is that locale files for plupload and jquery.validate don't follow our locale conventions; currently the mapping from our locale codes to their files isn't 1:1 and won't always work. Find a low-maintenance way to fix it.
Comment 2 Alec Smecher 2014-03-28 06:24:02 PDT
Use jquery validator locale files properly
https://github.com/pkp/omp/commit/074076408a81791bfe85457880330e69f604e420
Comment 3 Alec Smecher 2014-03-28 12:32:45 PDT
Pull requests for this:

https://github.com/pkp/pkp-lib/pull/74
https://github.com/pkp/omp/pull/13
Comment 4 Alec Smecher 2014-03-28 21:48:02 PDT
Use jquery validator locale files properly
https://github.com/pkp/pkp-lib/commit/3dc0328161305d0d619f5a428db81ef7dfb9c538
Comment 5 Alec Smecher 2014-03-31 10:36:02 PDT
Use plupload locale files properly
https://github.com/pkp/pkp-lib/commit/ffedb3dd3b5547563023aa567e62624384f754a7
Comment 6 Alec Smecher 2014-03-31 10:36:02 PDT
Use jquery validator locale files properly
https://github.com/pkp/pkp-lib/commit/ca3ad46011aa0b2a8f732e0de16d5a94615703cb
Comment 7 Alec Smecher 2014-03-31 10:38:01 PDT
Use jquery validator locale files properly
https://github.com/pkp/omp/commit/2b57151f8bf6c4fadee2706fc0e825e06fef875b
Comment 8 Alec Smecher 2014-03-31 10:38:51 PDT
Ported from omp-stable-1_1 to OMP and OJS master.
Comment 9 Alec Smecher 2014-03-31 10:39:02 PDT
Use jquery validator locale files properly
https://github.com/pkp/ojs/commit/62f3cc71ede9b1ba0990806b5dc04554ceb60852