We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6413 - Can't change order of custom blocks
Can't change order of custom blocks
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: User Interface
2.3.4
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-15 09:47 PST by James MacGregor
Modified: 2011-08-24 10:17 PDT (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OCS 2.3.3-1 (564 bytes, patch)
2011-03-31 10:11 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-02-15 09:47:37 PST
It appears that any custom blocks that are created can't be reordered in Website Management Setup Step 4. I have block one, block two, ... block n listed at the top of the right sidebar. I can move them up and down on the sidebar using the arrow buttons, but when I save the page their new state isn't recorded. 

I can move any other block (eg. the Developed By block) around and their new position will save, with the exception that I can't move a block above any of the custom blocks. 

Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=3&t=7134&p=27675#p27675.
Comment 1 James MacGregor 2011-02-15 09:48:46 PST
Another quick note -- I can't move the custom blocks into the middle or left boxes, either.
Comment 2 Scott 2011-03-31 08:51:46 PDT
Any updates or temporary workarounds for this? I'm trying to replicate our old site using the new version of OJS and would love to be able to place custom blocks in the left sidebar.
Comment 3 Alec Smecher 2011-03-31 10:11:53 PDT
Created attachment 3477 [details]
Patch against OCS 2.3.3-1

I think this is a partial dupe of bug #4887 -- but can you try the attached patch and see if it fixes the problem?
Comment 4 Scott 2011-04-01 11:33:27 PDT
I applied the patch but am still having the same problem. Interestingly, the original poster of bug #4887 was able to do what I can't:

"Block was already on the right sidebar, I went to Setup 5.6 and move the
Directors block from the right sidebar, to the middle, and then to the left
sidebar, saved.

The Directors block appeared as expected on the left sidebar."

That's what I'm having an issue with... moving custom blocks from the right sidebar to the left sidebar. Has anything changed from OJS 2.3.3 (bug #4887) that could have caused this issue?
Comment 5 Alec Smecher 2011-08-24 10:17:33 PDT
Scott, not sure if you found a work-around, but that's unrelated to this issue; this fix is definitely correct (at least for the bug in question). I suspect you're encountering a permissions problem in your cache/ directory.