We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6407 - Allow searching by submission ID
Allow searching by submission ID
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Editors
2.3.x
All All
: P3 normal
Assigned To: PKP Support
: 6380 6892 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-14 12:31 PST by Alec Smecher
Modified: 2014-09-08 22:28 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS pre-2.3.5 (6.84 KB, patch)
2011-02-14 12:55 PST, Alec Smecher
Details | Diff
Additional patch against OJS pre-2.3.5 (3.94 KB, patch)
2011-02-14 13:00 PST, Alec Smecher
Details | Diff
Patch against OCS pre-2.3.4 (4.36 KB, patch)
2011-02-14 13:14 PST, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2011-02-14 12:31:41 PST
Allow searching by submission ID on the various editorial workflow search forms.
Comment 1 Alec Smecher 2011-02-14 12:55:05 PST
Created attachment 3434 [details]
Patch against OJS pre-2.3.5
Comment 2 Alec Smecher 2011-02-14 13:00:54 PST
Created attachment 3435 [details]
Additional patch against OJS pre-2.3.5
Comment 3 Alec Smecher 2011-02-14 13:14:38 PST
Created attachment 3436 [details]
Patch against OCS pre-2.3.4
Comment 4 Alec Smecher 2011-10-14 09:37:51 PDT
*** Bug 6892 has been marked as a duplicate of this bug. ***
Comment 5 Alec Smecher 2012-09-24 09:12:00 PDT
*** Bug 6380 has been marked as a duplicate of this bug. ***
Comment 6 James MacGregor 2014-09-08 21:48:28 PDT
I don't think the OCS patch was ever committed. I just had a client request this, which I added to their system, and I think it's worth submitting to OCS. Reopening for now.
Comment 7 James MacGregor 2014-09-08 22:27:56 PDT
committed to ocs-stable-2_3. note that there was a problem with the original patch not passing a $request object to its functions. The patch here works with OCS 2.3.5: 

https://github.com/pkp/ocs/commit/03b0a1b26d7c4830ea79c51c04b8cf09052eecab.diff
Comment 8 James MacGregor 2014-09-08 22:28:03 PDT
Allow searching by submission ID
https://github.com/pkp/ocs/commit/03b0a1b26d7c4830ea79c51c04b8cf09052eecab