Bug 6389 - Primary Contact Affiliation in About page displays "array"
Primary Contact Affiliation in About page displays "array"
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: General
2.3.4
All All
: P3 normal
Assigned To: PKP Support
: 6101 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-06 22:51 PST by James MacGregor
Modified: 2011-08-17 15:05 PDT (History)
5 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OCS 2.3.3-1 (569 bytes, patch)
2011-08-17 14:56 PDT, Michael Felczak
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-02-06 22:51:03 PST
Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=3&t=7134&p=27583#p27540, point 4:

4) When in the Website Management>Step 1. About the Conference, I enter anything inside the textarea for "Affiliation" for the Principal Contact for Conference Website, then in the About the Conference > Conference Contact page, the word "Array" shows up underneath the contact's title...
...if I clear the "Affiliation" field in Step1 of the Website Management, About the Conference, then the that word disappear

This seems to be possibly related to Bug 6101 (which should probably be evaluated) although I don't think they are the same problem. If I apply Radomir's fix from Bug 6101 I can still replicate the problem, above. Anything I add to the affiliations field seems to be saved in the DB; in this case, it's just a problem retrieving it.
Comment 1 Michael Felczak 2011-08-17 14:56:09 PDT
Created attachment 3616 [details]
Patch against OCS 2.3.3-1
Comment 2 Michael Felczak 2011-08-17 14:58:14 PDT
Fixed.
Comment 3 Michael Felczak 2011-08-17 14:59:11 PDT
*** Bug 6101 has been marked as a duplicate of this bug. ***
Comment 4 Michael Felczak 2011-08-17 15:00:02 PDT
Primary Contact Affiliation in About page displays "array"
https://github.com/pkp/ocs/commit/09867221e9f080dbb456c4711bc439f6b7976f06
Comment 5 Michael Felczak 2011-08-17 15:05:01 PDT
Primary Contact Affiliation in About page displays "array"
https://github.com/pkp/ocs/commit/5c674c6149ad4e3feca47dd2fc8666d26263b43b