Bug 6388 - Cancelling Registration enrollment leads to 404
Cancelling Registration enrollment leads to 404
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: General
2.3.4
All All
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-06 22:33 PST by James MacGregor
Modified: 2011-02-07 08:36 PST (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OCS 2.3.3-1. (1.06 KB, patch)
2011-02-06 22:35 PST, James MacGregor
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2011-02-06 22:33:25 PST
Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=3&t=7134&p=27540#p27540: 

clicking Home > Conference Title > User > Conference Site Management > Registrations > Create > Enroll > Cancel leads to a 404. George reports the following URL: 


http://www.example.com/ocs/index.php/set_path1/set_path2/manager/registrations

... the problem being that "registrations" should be "registration". 

I've replicated this. The problem is in templates/registration/registrationForm.tpl -- the last url op should point to 'registration', not 'registrations'.
Comment 1 James MacGregor 2011-02-06 22:35:23 PST
Created attachment 3424 [details]
Patch against OCS 2.3.3-1.