Bug 6268 - Fatal error: Call to a member function getId () in AuthorAction.inc.php on line 154
Fatal error: Call to a member function getId () in AuthorAction.inc.php on li...
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Authors
2.3.4
All All
: P3 blocker
Assigned To: PKP Support
: 6391 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-01 11:09 PST by abel
Modified: 2011-02-09 07:49 PST (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.3-3 (712 bytes, patch)
2010-12-01 15:11 PST, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description abel 2010-12-01 11:09:42 PST
OJS Version: 2.3.3-3
Operating System Version: 5.0.7 Debian
PHP Version: 5.2.6-1 lenny9


Error description:

When I access the link as author: 
"http://xxx.xxx.xxx.xxx/ojs/index.php/nt/author/completeAuthorCopyedit?articleId=4"

The screen for email and when you click the button "Send" button or the "No email" link appears:
"http://xxx.xxx.xxx.xxx/ojs/index.php/nt/author/completeAuthorCopyedit/send"

and the following error message:
"Fatal error: Call to a member function getId () on a non-object in /var/www/ojs/classes/submission/author/AuthorAction.inc.php on line 154"
Comment 1 Alec Smecher 2010-12-01 15:11:29 PST
Created attachment 3379 [details]
Patch against OJS 2.3.3-3

Affects copyediting in workflows without assigned external copyeditors.
Comment 2 Alec Smecher 2011-02-09 07:49:56 PST
*** Bug 6391 has been marked as a duplicate of this bug. ***