Bug 6246 - OJS 2.3.3 Upgrade Fails on PHP4
OJS 2.3.3 Upgrade Fails on PHP4
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Installer
2.3.4
All All
: P3 major
Assigned To: Michael Felczak
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-24 11:08 PST by Michael Felczak
Modified: 2011-04-12 09:01 PDT (History)
3 users (show)

See Also:
Version Reported In: 2.3.3
Also Affects:


Attachments
Patch against OJS 2.3.3 (458 bytes, patch)
2010-11-24 11:11 PST, Michael Felczak
Details | Diff
Patch against OJS 2.3.3 (457 bytes, patch)
2010-11-26 12:59 PST, Michael Felczak
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Felczak 2010-11-24 11:08:12 PST
installFilterTemplates in lib/pkp/classes/install/Installer.inc.php:641 checks for PHP4 and returns false, causing the upgrade process to halt with error.
Comment 1 Michael Felczak 2010-11-24 11:11:27 PST
Created attachment 3352 [details]
Patch against OJS 2.3.3
Comment 2 Michael Felczak 2010-11-24 15:30:33 PST
Fixed, but not yet committed to lib-pkp.
Comment 3 Michael Felczak 2010-11-26 12:59:19 PST
Created attachment 3361 [details]
Patch against OJS 2.3.3

Updated patch format for consistency with our recommended patches instructions.
Comment 4 James MacGregor 2011-04-11 16:32:17 PDT
Hi Michael, should this be closed? (Just going through some open OJS bugs atm)
Comment 5 Michael Felczak 2011-04-12 09:01:23 PDT
Has been committed to lib-pkp:
https://github.com/pkp/pkp-lib/commit/e9f44b3a2219461a163a89735dab0152e2ed35a9

Closing.