We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6244 - Remove either the review type or have a single review workflow step.
Remove either the review type or have a single review workflow step.
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: General
1.0
PC Linux
: P3 normal
Assigned To: Juan Pablo Alperin
Depends on:
Blocks: 6410
  Show dependency treegraph
 
Reported: 2010-11-24 07:47 PST by jerico
Modified: 2011-12-13 12:05 PST (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerico 2010-11-24 07:47:30 PST
We currently have both, two workflow step constants for the review process and the review type field in the monograph. This is redundant information, creates code duplication and an unnecessary potential for inconsistent data and error. We should either remove the distinction between the two WORKFLOW_STAGE_* variables or remove the review type field then.
Comment 1 jerico 2011-02-22 12:52:08 PST
Current bugs caused by this inconsistency:
- workflow stage policies have WORKFLOW_STAGE_ID_REVIEW_INTERNAL hard coded
- a unique mapping from file stages to workflow stages is not possible (e.g. required for authorization of files) which means that file access can not be correctly authorized
Comment 2 jerico 2011-03-01 14:57:53 PST
Make sure that stage assignments in setup and default signoffs (stage participants) are compatible with the chosen solution.
Comment 3 jerico 2011-03-01 14:59:47 PST
Consider removing review type completely and count review rounds from 1 to n across both internal and external review and retrieve the review type passing by file -> submission -> workflow stage and leave the two different workflow stages in there.
Comment 5 Juan Pablo Alperin 2011-07-22 15:40:02 PDT
files grid fallback on request var for stageId and data providers always get stageId from containing grid.
https://github.com/pkp/omp/commit/b1bcac109dbf7f24bef67306c4740440fe6eb3d0
Comment 6 Alec Smecher 2011-12-13 12:05:02 PST
Removed old FIXME
https://github.com/pkp/omp/commit/34d4521e74b40370678ec94b3d6f2ab90caafc99