Bug 6220 - OJS 2.3.3 upgrade process incorrect for OJS 2.1.1
OJS 2.3.3 upgrade process incorrect for OJS 2.1.1
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Installer
2.3.4
All All
: P3 normal
Assigned To: PKP Support
: 6358 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-18 08:23 PST by Alec Smecher
Modified: 2011-01-31 12:13 PST (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.3-3 (9.69 KB, patch)
2010-11-18 08:34 PST, Alec Smecher
Details | Diff
Patch against OJS 2.3.3-3 (9.69 KB, patch)
2010-11-18 09:35 PST, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2010-11-18 08:23:15 PST
OJS 2.3.3 upgrade process incorrect for OJS 2.1.1 (and potentially a few surrounding versions); the 2.3.3 pre-update script may not be run when needed e.g. to migrate article_authors to authors.
Comment 1 Alec Smecher 2010-11-18 08:34:04 PST
Created attachment 3338 [details]
Patch against OJS 2.3.3-3
Comment 2 Alec Smecher 2010-11-18 09:35:10 PST
Created attachment 3339 [details]
Patch against OJS 2.3.3-3
Comment 3 James MacGregor 2011-01-21 12:23:33 PST
*** Bug 6358 has been marked as a duplicate of this bug. ***