Bug 6172 - problems when trying to promote submission from review to copyediting stage
problems when trying to promote submission from review to copyediting stage
Status: RESOLVED DUPLICATE of bug 6747
Product: OMP
Classification: Unclassified
Component: General
1.0
PC Linux
: P3 normal
Assigned To: Matthew Crider
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-10 17:59 PST by jerico
Modified: 2011-07-14 15:24 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerico 2010-11-10 17:59:27 PST
When promoting from the review stage to the copyediting stage with two review files and two revision files, I get:

[Wed Nov 10 23:51:39 2010] [error] [client ::1] NOTICE: Undefined index: 5 (pkp-omp/controllers/modals/editorDecision/form/PromoteForm.inc.php:206), referer: http://localhost/pkp-omp/index.php/test/workflow/review/3
[Wed Nov 10 23:51:39 2010] [error] [client ::1] omp has produced an error
  Message: WARNING: mime_content_type(): File or path not found 'pkp-omp/files/presses/1/monographs/3/submission/review/##_2010-Chapter-7-1.doc'
  In file: pkp-omp/lib/pkp/classes/core/String.inc.php
  At line: 370
  Stacktrace:
   File: (unknown) line (unknown)
     Function: PKPApplication->errorHandler(2, "mime_content_type(): File or path not found 'pkp-omp/files/presses/1/monographs/3/submission/review/##_2010-Chapter-7-1.doc'", "pkp-omp/lib/pkp/classes/core/String.inc.php", 370, Array(1))
   File: pkp-omp/lib/pkp/classes/core/String.inc.php line 370
     Function: mime_content_type("pkp-omp/files/presses/1/monographs/3/submission/review/##_2010-Chapter-7-1.doc")
   File: pkp-omp/lib/pkp/classes/mail/Mail.inc.php line 197
     Function: String->mime_content_type("pkp-omp/files/presses/1/monographs/3/submission/review/##_2010-Chapter-7-1.doc")
   File: pkp-omp/controllers/modals/editorDecision/form/PromoteForm.inc.php line 206
     Function: Mail->addAttachment("pkp-omp/files/presses/1/monographs/3/submission/review/##_2010-Chapter-7-1.doc", "A-ZG_Einladung_World_Cafe.doc")
   File: pkp-omp/controllers/modals/editorDecision/EditorDecisionHandler.inc.php line 210
     Function: PromoteForm->execute(Array(4), Object(Request))
   File: (unknown) line (unknown)
     Function: EditorDecisionHandler->savePromote(Array(4), Object(Request))
Comment 1 Juan Pablo Alperin 2011-07-14 15:24:14 PDT

*** This bug has been marked as a duplicate of bug 6747 ***