Bug 6129 - Implement distinction between internal and external review
Implement distinction between internal and external review
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: General
1.0b
PC Linux
: P3 normal
Assigned To: Matthew Crider
: 6102 6126 (view as bug list)
Depends on:
Blocks: 6410
  Show dependency treegraph
 
Reported: 2010-11-03 18:16 PDT by jerico
Modified: 2011-02-14 17:21 PST (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerico 2010-11-03 18:16:36 PDT
See our mail conversation about internal/external reviews:

- Distinguish between internal and external review.
- Create default user groups for internal and external reviewers.
- Replace get/setReviewType() by corresponding MONOGRAPH_FILE_REVIEW_{INTERNAL|EXTERNAL} constants
Comment 1 jerico 2010-11-04 18:50:30 PDT
*** Bug 6102 has been marked as a duplicate of this bug. ***
Comment 2 jerico 2010-11-04 18:50:47 PDT
*** Bug 6126 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Crider 2010-11-05 10:45:22 PDT
We won't need two MONOGRAPH_FILE_REVIEW_{INTERNAL|EXTERNAL} constants, just one MONOGRAPH_FILE_REVIEW.  The review type should be tracked in the review_round_files table.

Getting a set of files for a review round will require querying the review_round_files table (and specifying the monograph_id, round, and review type)
Comment 4 Matthew Crider 2010-11-05 10:49:40 PDT
Also, we need to remove the round column from monograph_files.  I'll open a separate bug to remind us to make this change in OJS/OCS (and migrate the review_round_files table).
Comment 5 Matthew Crider 2010-11-05 11:00:36 PDT
Two more things:
-We need to adjust all breadcrumbs to show 'internal review' and 'external review' instead of just 'review'
-The methods to access the review_round_files table are in the reviewAssignmentDAO.  They would be more appropriate in the reviewRoundDAO.  They are also rather incomplete in their implementation (and are probably not being used as they should in the review classes).