Bug 6121 - lib/pkp/locale/en_US/languages.xml needs to be translated
lib/pkp/locale/en_US/languages.xml needs to be translated
Status: RESOLVED WORKSFORME
Product: OJS
Classification: Unclassified
Component: Plug-ins
2.4.0
All All
: P3 normal
Assigned To: Michael Felczak
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-03 05:53 PDT by Marco Tullney
Modified: 2012-08-09 10:05 PDT (History)
3 users (show)

See Also:
Version Reported In: 2.3.3
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marco Tullney 2010-11-03 05:53:07 PDT
lib/pkp/locale/en_US/languages.xml contains a list of languages. It is used in the built-in Books for review plug-in to choose the language of a book from a drop-down list. This choice is necessary to complete the form of createBookForReview. Since this particular file is missing in any other language, there's no way of adding books for review when you use the UI in any other language than en_US.

workaround: copy the file from en_US to the other locales' folders
real solution: have the file translated
Comment 1 jerico 2010-11-08 08:08:54 PST
Michael, am I right that the book review stuff was "yours"? If it's not just assign back to pkp-support.
Comment 2 Michael Felczak 2010-11-08 18:31:33 PST
Hi Marco, thanks for the bug report.

Leaving open with your suggested workaround until this is translated.

@Florian: yes, thanks.
Comment 3 Alec Smecher 2012-08-09 10:05:52 PDT
The languages list is included in the translator plugin as a miscellaneous file; translators should be asked by the plugin to create it. If that file is not included some features of the system may not work fully; this is expected behavior.