We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6101 - Error while submitting "Scheduled Conference Setup / Details - Step 1" form
Error while submitting "Scheduled Conference Setup / Details - Step 1" form
Status: RESOLVED DUPLICATE of bug 6389
Product: OCS
Classification: Unclassified
Component: General
2.3.3
PC Windows XP
: P5 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-01 17:06 PDT by radomir
Modified: 2011-08-17 14:59 PDT (History)
3 users (show)

See Also:
Version Reported In: 2.3.3
Also Affects: OCS 2.1.3, OCS 2.3.2, OCS 2.3.3


Attachments
php error dump (2.22 KB, text/plain)
2010-11-01 17:06 PDT, radomir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description radomir 2010-11-01 17:06:55 PDT
Created attachment 3318 [details]
php error dump

SchedConfSetupStep1Form stores everything in database except Principal Contact's Affiliation (under section 1.3 on /index.php/epns/2011/manager/schedConfSetup/1).

"contactAffiliation" field of the scheduled conference is being parsed as an array, instead as a string, resulting in PHP error while "escaping" the array value (when tested with MySQL, mysql_real_escape_string() fails).

CAUSE:
- "contactAffiliation" field is not being processed as a localized settings option.

PATCH:
in: ocs/classes/manager/form/schedConfSetup/SchedConfSetupStep1Form.inc.php
line: 65
- return array('introduction', 'overview', 'emailSignature', 'sponsorNote', 'contributorNote');
+ return array('introduction', 'overview', 'contactAffiliation', 'emailSignature', 'sponsorNote', 'contributorNote');
Comment 1 r2d2 2011-03-27 09:30:54 PDT
This is still an issue in OCS 2.3.3-1. Here is the problem:

The Affiliation field for Principal Contact that is entered in Scheduled Conference Setup Step1 is displayed as the word "Array" in Contact page: http://pkp.sfu.ca/ocs/pkp/index.php/pkp2011/index/about/contact
Comment 2 Michael Felczak 2011-08-17 14:59:11 PDT

*** This bug has been marked as a duplicate of bug 6389 ***