Bug 6080 - TinyMCE converts to HTML entities
TinyMCE converts to HTML entities
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Plug-ins
2.3.4
All All
: P5 normal
Assigned To: Michael Felczak
: 6880 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-28 12:20 PDT by Michael Felczak
Modified: 2011-09-14 15:25 PDT (History)
4 users (show)

See Also:
Version Reported In: 2.3.3
Also Affects: OCS 2.1.3, OCS 2.3.4, OHS 2.3.2, OJS 2.2.5, OJS 2.3.4, OMP 1.0


Attachments
Patch against OJS 2.3.3 (565 bytes, patch)
2010-11-19 16:40 PST, Michael Felczak
Details | Diff
Patch against OJS 2.2.4 (545 bytes, patch)
2010-11-19 16:41 PST, Michael Felczak
Details | Diff
Patch against OCS 2.3.3 (556 bytes, patch)
2010-11-19 16:42 PST, Michael Felczak
Details | Diff
Patch against OCS 2.1.2 (545 bytes, patch)
2010-11-19 16:42 PST, Michael Felczak
Details | Diff
Patch against OHS 2.3.1 (565 bytes, patch)
2010-11-19 16:44 PST, Michael Felczak
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Felczak 2010-10-28 12:20:42 PDT
Rather than passing through text based on a page's charset, by default TinyMCE is converting to HTML entities.

Set TinyMCE encoding option to "raw" (preserve charset, only convert XML default entitites).

See:
http://wiki.moxiecode.com/index.php/TinyMCE:Configuration/entity_encoding
http://wiki.moxiecode.com/index.php/TinyMCE:Configuration/encoding
Comment 1 Michael Felczak 2010-11-19 16:40:39 PST
Created attachment 3346 [details]
Patch against OJS 2.3.3
Comment 2 Michael Felczak 2010-11-19 16:41:16 PST
Created attachment 3347 [details]
Patch against OJS 2.2.4
Comment 3 Michael Felczak 2010-11-19 16:42:13 PST
Created attachment 3348 [details]
Patch against OCS 2.3.3
Comment 4 Michael Felczak 2010-11-19 16:42:46 PST
Created attachment 3349 [details]
Patch against OCS 2.1.2
Comment 5 Michael Felczak 2010-11-19 16:44:15 PST
Created attachment 3350 [details]
Patch against OHS 2.3.1
Comment 6 Michael Felczak 2010-11-19 16:55:05 PST
Fixed.
Comment 7 Michael Felczak 2011-09-14 12:40:02 PDT
TinyMCE converts to HTML entities
https://github.com/pkp/ocs/commit/17c10a21c7bcdcef430d250afc00c2e65c99ea8a
Comment 8 James MacGregor 2011-09-14 13:47:51 PDT
*** Bug 6880 has been marked as a duplicate of this bug. ***
Comment 9 Michael Felczak 2011-09-14 15:25:03 PDT
The original stable commit was against ocs-archive-2_2 and wasn't ported to ocs-stable-2_3 when the latter was created.