Bug 6068 - User interests controlled vocab entries check assoc_id without specifying assoc_type
User interests controlled vocab entries check assoc_id without specifying ass...
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: General
2.3.3
PC Linux
: P5 enhancement
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-25 13:50 PDT by Alec Smecher
Modified: 2010-10-29 17:46 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.3-2 (6.60 KB, patch)
2010-10-25 14:06 PDT, Alec Smecher
Details | Diff
Patch against PKP pre-release (3.37 KB, patch)
2010-10-25 14:06 PDT, Alec Smecher
Details | Diff
Patch against OCS pre-2.3.4 (6.12 KB, patch)
2010-10-25 14:13 PDT, Alec Smecher
Details | Diff
Patch against OMP pre-release (3.80 KB, patch)
2010-10-25 14:15 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2010-10-25 13:50:31 PDT
User interests controlled vocab entries check assoc_id without specifying assoc_type. This may lead to collisions between controlled vocab entries used for different purposes and also prevents the database from using the related indexes.
Comment 1 Alec Smecher 2010-10-25 14:06:18 PDT
Created attachment 3296 [details]
Patch against OJS 2.3.3-2
Comment 2 Alec Smecher 2010-10-25 14:06:46 PDT
Created attachment 3297 [details]
Patch against PKP pre-release
Comment 3 Alec Smecher 2010-10-25 14:13:06 PDT
Created attachment 3298 [details]
Patch against OCS pre-2.3.4
Comment 4 Alec Smecher 2010-10-25 14:15:24 PDT
Created attachment 3299 [details]
Patch against OMP pre-release
Comment 5 Alec Smecher 2010-10-25 14:16:25 PDT
Corrected for all apps. To fix this for OJS 2.3.3-2, for example, both attachment #3297 [details] (in lib/pkp) and attachment #3296 [details] (in the install directory) need to be applied.
Comment 6 Alec Smecher 2010-10-29 17:46:40 PDT
Committed to OJS 2.3.3-3