Bug 6063 - Upgrading from 2.2.4 to 2.3.3 fails with PostgreSQL
Upgrading from 2.2.4 to 2.3.3 fails with PostgreSQL
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Installer
2.3.3
PC Linux
: P5 enhancement
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-25 03:33 PDT by Tom Christensen
Modified: 2010-10-29 16:34 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.3-2 (978 bytes, patch)
2010-10-25 03:34 PDT, Tom Christensen
Details | Diff
Patch against PKP pre-release (623 bytes, patch)
2010-10-25 13:16 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tom Christensen 2010-10-25 03:33:33 PDT
Upgrading from 2.2.4 to 2.3.3 fails when the database used is postgresql.

A fix for this was made in bz#6023 but it is incomplete as documented here:
http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=6660
Comment 1 Tom Christensen 2010-10-25 03:34:56 PDT
Created attachment 3290 [details]
Patch against OJS 2.3.3-2
Comment 2 Alec Smecher 2010-10-25 13:16:00 PDT
Created attachment 3295 [details]
Patch against PKP pre-release

Attached patch is equivalent to attachment #3290 [details], but for consistency, it's generated from the PKP library's working directory (lib/pkp). Only one of the two need to be applied.
Comment 3 Alec Smecher 2010-10-25 13:16:12 PDT
Thanks for contributing, Tom!
Comment 4 Alec Smecher 2010-10-29 16:34:03 PDT
Fixing for the OJS 2.3.3-3 incremental release.