We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6036 - PHP fatal error when clearing reviewer
PHP fatal error when clearing reviewer
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Reviewers
2.3.3
PC Mac OS X 10.6
: P5 normal
Assigned To: PKP Support
: 6055 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-12 15:01 PDT by James MacGregor
Modified: 2010-10-29 17:13 PDT (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.3-2 (1.54 KB, patch)
2010-10-29 17:12 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2010-10-12 15:01:08 PDT
When I click the "Clear Reviewer" link next to a reviewer on any submission review page, I get the following fatal errors: 

[Tue Oct 12 14:58:30 2010] [error] [client 127.0.0.1] NOTICE: Undefined offset: 0 (/Users/jmacgreg/git/ojs/classes/submission/sectionEditor/SectionEditorSubmission.inc.php:96), referer: http://git/ojs/index.php/citation/editor/submissionReview/26

[Tue Oct 12 14:58:30 2010] [error] [client 127.0.0.1] PHP Fatal error:  Call to a member function getReviewId() on a non-object in /Users/jmacgreg/git/ojs/classes/submission/sectionEditor/SectionEditorSubmission.inc.php on line 96, referer: http://git/ojs/index.php/citation/editor/submissionReview/26

The reviewer is not cleared. 

(Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=6685&p=25773#p25773)
Comment 1 jerico 2010-10-22 14:35:52 PDT
*** Bug 6055 has been marked as a duplicate of this bug. ***
Comment 2 Alec Smecher 2010-10-29 17:12:20 PDT
Created attachment 3317 [details]
Patch against OJS 2.3.3-2
Comment 3 Alec Smecher 2010-10-29 17:13:06 PDT
Committing for OJS 2.3.3-3.