We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 6022 - Error when uploading a replacement supplementary file
Error when uploading a replacement supplementary file
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Submissions and Publishing
2.3.3
PC Mac OS X 10.6
: P5 enhancement
Assigned To: PKP Support
: 6066 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-10-06 14:12 PDT by Matthew Crider
Modified: 2010-10-29 17:46 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
Patch against OJS 2.3.3-2 (1.70 KB, patch)
2010-10-25 12:04 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Crider 2010-10-06 14:12:57 PDT
Uploading a replacement supp. file (i.e upload a supp file, then upload another to replace it) causes an error -- It looks like the call to SuppFileForm in TrackSubmissionHandler::284 is missing a parameter:
 Wednesday, October 6, 2010 1:57:56 PM America/Vancouver 
[06-Oct-2010 14:00:53] PHP Fatal error:  Call to a member function getSetting() on a non-object in /Applications/MAMP/htdocs/dev/ojs/classes/submission/form/SuppFileForm.inc.php on line 36
[06-Oct-2010 14:00:53] PHP Stack trace:
[06-Oct-2010 14:00:53] PHP   1. {main}() /Applications/MAMP/htdocs/dev/ojs/index.php:0
[06-Oct-2010 14:00:53] PHP   2. PKPApplication->execute() /Applications/MAMP/htdocs/dev/ojs/index.php:65
[06-Oct-2010 14:00:53] PHP   3. Dispatcher->dispatch($request = *uninitialized*) /Applications/MAMP/htdocs/dev/ojs/lib/pkp/classes/core/PKPApplication.inc.php:180
[06-Oct-2010 14:00:53] PHP   4. PKPPageRouter->route($request = *uninitialized*) /Applications/MAMP/htdocs/dev/ojs/lib/pkp/classes/core/Dispatcher.inc.php:129
[06-Oct-2010 14:00:53] PHP   5. PKPRouter->_authorizeInitializeAndCallRequest($serviceEndpoint = *uninitialized*, $request = *uninitialized*, $args = *uninitialized*, $validate = *uninitialized*) /Applications/MAMP/htdocs/dev/ojs/lib/pkp/classes/core/PKPPageRouter.inc.php:265
[06-Oct-2010 14:00:53] PHP   6. call_user_func(*uninitialized*, *uninitialized*, *uninitialized*) /Applications/MAMP/htdocs/dev/ojs/lib/pkp/classes/core/PKPRouter.inc.php:370
[06-Oct-2010 14:00:53] PHP   7. TrackSubmissionHandler->saveSuppFile($args = *uninitialized*, *uninitialized*) /Applications/MAMP/htdocs/dev/ojs/lib/pkp/classes/core/PKPRouter.inc.php:0
[06-Oct-2010 14:00:53] PHP   8. SuppFileForm->SuppFileForm($article = *uninitialized*, $journal = *uninitialized*, $suppFileId = *uninitialized*) /Applications/MAMP/htdocs/dev/ojs/pages/author/TrackSubmissionHandler.inc.php:284
Comment 2 Alec Smecher 2010-10-25 12:02:25 PDT
*** Bug 6066 has been marked as a duplicate of this bug. ***
Comment 3 Alec Smecher 2010-10-25 12:04:51 PDT
Created attachment 3291 [details]
Patch against OJS 2.3.3-2

(Uploaded patch file is equivalent to Matt's link in comment #1.)
Comment 4 Alec Smecher 2010-10-29 17:46:28 PDT
Committed to OJS 2.3.3-3