We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 5913 - Monograph class contains duplicate author-related accessors that are already implemented in Submission.
Monograph class contains duplicate author-related accessors that are already ...
Status: RESOLVED DUPLICATE of bug 5231
Product: OMP
Classification: Unclassified
Component: General
1.0
PC Linux
: P3 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-09-20 09:41 PDT by jerico
Modified: 2011-03-20 23:46 PDT (History)
0 users

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerico 2010-09-20 09:41:02 PDT
See getAuthorString() and getAuthorEmails(), also probably getAuthors() and getPrimaryAuthor(). What's the reason why a "primary author" only makes sense in OMP but not in OJS/OCS? I'd guess that this is a notion that would be good for all apps and therefore reside in Submission rather than Monograph only.

If this is just an open migration task then please make an entry on our migration task wiki page pointing to this bugzilla entry.
Comment 1 Juan Pablo Alperin 2011-03-20 23:46:15 PDT
flagged for backporting in bugzilla at other entry.

*** This bug has been marked as a duplicate of bug 5231 ***