We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 5807 - Implement common user home page ("submission list")
Implement common user home page ("submission list")
Status: RESOLVED FIXED
Product: OMP
Classification: Unclassified
Component: General
1.0
PC Linux
: P3 normal
Assigned To: jerico
: 5641 (view as bug list)
Depends on:
Blocks: 5321
  Show dependency treegraph
 
Reported: 2010-08-24 20:23 PDT by jerico
Modified: 2010-09-01 20:47 PDT (History)
2 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description jerico 2010-08-24 20:23:49 PDT
Juan wrote: "I think the grids that are currently loading at /editor /author, for example, should be loading at /submissions (or arguably at /submission/list) . the grid that loads should change depending on the actingAsUserGroupId."

Juan, I'd like to tackle this next. Is there something about this /submission/list page in the spec already or do we have some wireframes from Brent? Is this the core of the famous "dashboard"?
Comment 1 Juan Pablo Alperin 2010-08-25 09:30:39 PDT
there is no spec for this page, but we can work on just having the submission list under the title "my submissions" or something like that.  This wont be the basis for the dashboard.  The dashboard will likely have a link that goes to here.
Comment 2 Juan Pablo Alperin 2010-08-25 09:44:59 PDT
*** Bug 5641 has been marked as a duplicate of this bug. ***
Comment 3 Juan Pablo Alperin 2010-08-25 09:46:35 PDT
we should also considering writing the submission details page.  At least a placeholder for it, until we actually sort out metadata stuff.
Comment 4 Matthew Crider 2010-08-25 10:46:42 PDT
Juan, that exists at <submission/details/#>.  Currently, only the file grid is in there, I'll pop the page header in there after the stage assignment code is finished.
Comment 5 jerico 2010-08-25 18:59:44 PDT
Juan, the SubmissionHandler already contains an index() method with a method comment that sounds like the page we're talking about. I propose we leave the page there (rather than moving it to /list) unless we have another sensible default page for the submission handler. As you've started to implement this: Do you intent to finish that template (which is currently empty) and leave only the user group part to me or do you want me to consolidate the grids from the /authors and /editors pages in there?
Comment 6 jerico 2010-08-25 19:28:09 PDT
Improved the classdoc to comply with our doc standards and added a dummy authorize() method until we fix #5815, see http://github.com/pkp/omp/commit/7ac51689443fa573685f943cb19e3ed0a5cca87d.
Comment 7 Juan Pablo Alperin 2010-08-26 10:02:55 PDT
(In reply to comment #5)

Go ahead and implement it yourself. I just got the process started, but it was mainly to have placeholders in there.  Doing it in index() seems fine.
Comment 8 jerico 2010-08-30 21:51:34 PDT
Fixed author and editor part as well as added authorize() method for all grids, see http://github.com/pkp/omp/commit/90f19afe710f35fd942d33f1c1ea47e48bd18fc7
Leaving open until reviewer part is complete also.
Comment 9 jerico 2010-09-01 11:39:22 PDT
Reviewer part is complete now, see http://github.com/pkp/omp/commit/364884578628ca5c782a3c7524d891dc88341244
Comment 10 Matthew Crider 2010-09-01 15:53:08 PDT
Florian, for some reason the editor submission list is only showing the 'decline submission' row action, and that and the send to review modals don't display anything in the modal.
Comment 11 jerico 2010-09-01 20:47:41 PDT
Matt, the editor submission problem is a duplicate of #5635 together with the missing locale component (which I added now), see http://github.com/pkp/omp/commit/7b50a029b03dc172adcd4c85151c36024bc8d32b
I haven't touched the review modals in this change set I hope so I'll add a new bug for that.