We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 5652 - Backup
Backup
Status: RESOLVED DUPLICATE of bug 4846
Product: OJS
Classification: Unclassified
Component: General
2.x
PC Mac OS X 10.6
: P5 enhancement
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 13:19 PDT by Ivo Welch
Modified: 2013-05-29 16:12 PDT (History)
1 user (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ivo Welch 2010-08-04 13:19:13 PDT
Suggestion: Add a "Backup Option" to the system administrator's menu, which follows the steps that you laid out in the "backup" section of the user guide.  (It would back up the critical files and data base.)  Presumably, the sysadmin would tell you a writeable directory, and this is where the full file with all components would be deposited.

Even better would be an automatic backup system, which runs every night, but this would be too much to ask.

regards,

/iaw
Comment 1 James MacGregor 2010-08-04 15:31:32 PDT
There is already a backup plugin for OCS (see http://pkp.sfu.ca/support/forum/viewtopic.php?f=28&t=4914). It might actually be worth thinking about porting this to OJS and adding to the stable of included plugins for both.
Comment 2 James MacGregor 2013-05-29 16:12:09 PDT
A Backup plugin was recently added to OJS (2.4.x IIRC).

*** This bug has been marked as a duplicate of bug 4846 ***