Bug 5642 - Article View enhancements
Article View enhancements
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: User Interface
2.3.3
PC Mac OS X 10.6
: P5 enhancement
Assigned To: Matthew Crider
: 4621 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 20:49 PDT by James MacGregor
Modified: 2010-09-23 17:11 PDT (History)
4 users (show)

See Also:
Version Reported In:
Also Affects: OCS 2.3.3


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2010-08-03 20:49:51 PDT
I think we could make a few minor tweaks to the article view template to better display the non-sidebar reading tools, specifically the AddThis button; the "Add Comment" link; and the "Download this PDF File" link. If enabled/available, they are currently haphazardly grouped at the bottom of the HTML or PDF galley file; there's no consistent number of line breaks between links, and they can take up a fair amount of real estate. 

1. There is already a "Post Comment" link in the sidebar, so I think the "Add Comment" link is redundant and can be removed. 

2. The Download PDF link can probably stay, even though the "Print this article" button accomplishes the same thing. It's pretty content- and object-specific. 

3. The AddThis button should probably be moved to the Article Tools / Reading Tools block. 

I know this is sort of sneaking in before the final deadline, but I'd really like to see these changes made -- it'll just tighten up the new article UI that much more. Any comments? I can probably do this over the next day or two if it's ok.
Comment 1 James MacGregor 2010-08-03 20:50:44 PDT
*** Bug 4621 has been marked as a duplicate of this bug. ***
Comment 2 Alec Smecher 2010-08-04 12:01:57 PDT
A note about #1 -- the "Add a comment" link was added to the main article pane recently to help encourage people to use the commenting feature. Previous to that, it was only on the reading tools sidebar and I suspect its lack of visibility was part of the reason that commenting was so rarely used.
Comment 3 Alec Smecher 2010-08-04 12:05:23 PDT
Also, I've recently asked Alex to have a look at the new PDF article view, particularly with respect to adding accordion-style hide/show of the RT sidebar, but it might be good to see if he has any suggestions for the scattering of tools on the main div.
Comment 4 Alex Garnett 2010-08-27 16:25:20 PDT
Accordion hide-show has been implemented -- it's functional, but not perfect:

- It's currently arranged along the main nav, but included in its own div. Would probably be better (especially when the left sidebar is enabled) to put this in its own column between the article view and the sidebar.

- There's no actual animating at present; I'm unable to use the jQuery toggle because it doesn't allow control over the direction of the animation, and all of the alternatives available to me using jQuery UI and animate() were sufficiently complex to break it.
Comment 5 Matthew Crider 2010-09-23 15:07:51 PDT
Done, implementing full screen mode instead of hiding sidebars: http://github.com/pkp/ojs/commit/fe4cb75e9909f59ebbdf205906588995f3b11f4e
Comment 6 Matthew Crider 2010-09-23 17:11:53 PDT
Additional changes after some testing from James:
-Cosmetic update to fullscreen mode (added a black 'lightbox' background)
-Fixed font size plugin in RT (script wasn't included in article header template)
-Bug fix for fullscreen mode link displaying in firefox without there being a PDF present (needed to install the PDFObject javascript from pdfobject.com--Using this is the only reliable way to detect if the PDF object has been embedded)

http://github.com/pkp/ojs/commit/774a4bc1c9239199d4b5c4e173ba9a926ff75e94