Bug 5543 - Implement multilingual spec
Implement multilingual spec
Status: RESOLVED FIXED
Product: PKP-LIB
Classification: Unclassified
Component: General
2.0
PC Linux
: P5 enhancement
Assigned To: Alec Smecher
: 5525 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-01 12:46 PDT by Alec Smecher
Modified: 2013-02-06 16:23 PST (History)
3 users (show)

See Also:
Version Reported In:
Also Affects: OCS 2.3.3, OHS 2.3.1, OJS 2.3.3, OMP 1.0


Attachments
Patch against OJS pre-2.3.2 CVS (19.34 KB, patch)
2010-07-01 14:59 PDT, Alec Smecher
Details | Diff
Patch against OJS pre-2.3.2 CVS (15.94 KB, patch)
2010-07-05 15:39 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2010-07-01 12:46:11 PDT
Implement the multilingual spec. See <https://secure.marbletank.com/redmine/wiki/omp/Multilingual_Input>. In brief:

   1.  Language is specified on a per-submission basis based on those locales specified in the press setup, and the submission files are for that language only.
   2. Translated metadata may be entered for each of those locales
   3. If the actual work (e.g. article, book) has been translated, it is considered a brand new submission.
   4. Users always by default enter information in the locale of the interface if the press accepts submission in that locale.
Comment 1 Alec Smecher 2010-07-01 14:59:23 PDT
Created attachment 3122 [details]
Patch against OJS pre-2.3.2 CVS

Step 1: move article primary locale into articles, instead of journals.
Comment 2 Alec Smecher 2010-07-01 15:23:03 PDT
Committed first part to OCS as well, http://github.com/pkp/ocs/commit/714ee6718303942886e2ed86ecb39f4b2ea4356a
Comment 3 Alec Smecher 2010-07-01 15:40:11 PDT
Also committed to OMP.

The following statements will revive your installs.

OJS
---
UPDATE articles a, journals j SET a.locale = j.primary_locale WHERE a.journal_id = j.journal_id

OCS
---
UPDATE papers p, conferences c, sched_confs sc SET p.locale = c.primary_locale WHERE p.sched_conf_id = sc.sched_conf_id AND sc.conference_id = c.conference_id

OMP
---
UPDATE monographs m, presses p SET m.locale = p.primary_locale WHERE m.press_id = p.press_id
Comment 4 Alec Smecher 2010-07-02 11:01:25 PDT
*** Bug 5525 has been marked as a duplicate of this bug. ***
Comment 5 Alec Smecher 2010-07-05 15:39:38 PDT
Created attachment 3125 [details]
Patch against OJS pre-2.3.2 CVS

Step 2: Add "submissions" checkboxes to manager's languages interface; allow choice for authors in beginning of submission process.
Comment 6 Alec Smecher 2010-07-06 10:38:02 PDT
Implemented step 2 in all apps. You probably need to go to your language settings page and choose some submission languages.
Comment 7 James MacGregor 2010-07-12 21:06:12 PDT
(In reply to comment #6)
> Implemented step 2 in all apps. You probably need to go to your language
> settings page and choose some submission languages.

This step is a problem if you only have one language (eg. English) installed at the journal level -- the JM isn't shown the different checkboxes for the one languages, but it doesn't appear that the submissions option is enabled by default for one language only. Let me know if this should be filed as a separate bug, but I thought I'd put it here as this one is still open.
Comment 8 Alec Smecher 2010-07-13 09:16:05 PDT
James, I've just committed a change that should address your comment #7.
Comment 9 James MacGregor 2010-07-13 09:36:00 PDT
(In reply to comment #8)
> James, I've just committed a change that should address your comment #7.

Hi Alec, I'm getting multiple strange/inconsistent behaviours with the language option now -- I'm going to investigate a little more thoroughly and post as a new bug if that's ok.
Comment 10 Juan 2013-01-16 02:54:01 PST
I've got 2.3.7 version. If I want to submit in a language different from the primary locale, I can't. The system requires me to submit only in this primary language
Comment 11 Alec Smecher 2013-01-16 08:25:29 PST
Juan, please post this at http://pkp.sfu.ca/support/forum -- it's the best place to go for this kind of support.
Comment 12 Alec Smecher 2013-01-16 08:26:24 PST
James, is this entry still relevant? I suspect not. See e.g. comment #9.