Bug 5483 - Allow multiple authors to access same article(s)
Allow multiple authors to access same article(s)
Status: RESOLVED DUPLICATE of bug 2928
Product: OJS
Classification: Unclassified
Component: Authors
2.x
PC Mac OS X 10.4
: P5 enhancement
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-05-31 09:59 PDT by James MacGregor
Modified: 2012-01-30 09:03 PST (History)
3 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2010-05-31 09:59:35 PDT
Allow multiple articles to work concurrently/cooperatively on the same article workflow. They should be able to log in and see the article in their submission queue; and access/upload to/from any stage in the Review and/or Editing process. 

A few things to keep in mind: 

-- this functionality should be togglable;
-- upload/revision collisions might be an issue, and should be taken into account;
-- might have to designate an authorship hierarchy, so that one author is always in charge (and not necessarily the contributing author);
-- that hierarchy may also dictate how author<->editor communication works;
-- may already be part of the OMP incubation plan?

(Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=2&t=6173&p=23737#p23737)
Comment 1 James MacGregor 2010-05-31 10:23:54 PDT
From another user (http://pkp.sfu.ca/support/forum/viewtopic.php?f=2&t=6173&p=23773#p23773): 

I would like to add my +1 to this issue. Offering co-authors view-and-read-only access would be much appreciated. In our case most articles have several authors, some have a dozen, and in many cases the selection of a primary author may be arbitrary as all authors were contributors. These co-authors should have the ability to at least see the status of their submitted work.
Comment 2 James MacGregor 2010-05-31 10:48:53 PDT
Further thoughts on this: 

-- Additional authors must be enrolled as Author users within OJS, and the submitting author should have an intelligent way of selecting them (eg. via intelligent drop-down/search); or there must be a way for the submitting Author to register them (ie. via a modal);

-- Editor/Author correspondence should take into account multiple Authors (ie. CCing the remaining Authors; etc.), and should possibly provide a way for Editors and individual Authors to communicate privately.
Comment 3 Alec Smecher 2010-07-20 12:52:56 PDT
Deferring.
Comment 4 Alec Smecher 2011-05-09 04:43:00 PDT

*** This bug has been marked as a duplicate of bug 2928 ***