Bug 5368 - Author submission status should include "Resubmit for review" status
Author submission status should include "Resubmit for review" status
Status: RESOLVED DUPLICATE of bug 3798
Product: OJS
Classification: Unclassified
Component: User Interface
2.3.3
PC Mac OS X 10.3
: P5 normal
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-26 16:04 PDT by James MacGregor
Modified: 2010-07-07 15:59 PDT (History)
1 user (show)

See Also:
Version Reported In: 2.3.1
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2010-04-26 16:04:36 PDT
They Author Submission status (the last column in the Author's submission queues) doesn't list when a request for resubmission has been sent -- the submission still lists as "In review". It should be a little more fine-grained than this, so that author can see that an action has been requested when looking at the submission queue. This already happens for Revisions Required. 

Status text should be: 

In Review: Resubmit for Review

... or: 

In Review: Resubmission Requested
Comment 1 Alec Smecher 2010-07-07 13:57:59 PDT
James, the current message is "In Review" for the first round and "In Review Round x" for subsequent rounds. I see your point, but there's no way of differentiating between "just re-entered review in round 2" and "still sitting in round 2 a month later" and "In Review Round x" covers both adequately IMO.
Comment 2 James MacGregor 2010-07-07 15:22:54 PDT
(In reply to comment #1)
> James, the current message is "In Review" for the first round and "In Review
> Round x" for subsequent rounds. I see your point, but there's no way of
> differentiating between "just re-entered review in round 2" and "still sitting
> in round 2 a month later" and "In Review Round x" covers both adequately IMO.

Hi Alec, I'm not entirely sure we're talking about the same issue: basically, I'm wondering if there's a way to indicate in that column that an action needs to be done, eg. Resubmit for review or (now that I think about it) Revision upload requested. 

Is there no way to get the current Editorial Decision, and if it's Resubmit for Review then display that (or something similar) alongside the status? The action to trigger this would be when the Editor sends an Author Notification->Resubmit for Review email. 

Of course, it may not be worth worrying about this right now, as it'll be taken care of eventually in the UI overhaul. If that's the case, please feel free to close.
Comment 3 Alec Smecher 2010-07-07 15:48:11 PDT
Gotcha. There's been additional information e.g. for "Revisions Requested" since bug #3798 was fixed, in version 2.2.3; are you looking at an older version?
Comment 4 James MacGregor 2010-07-07 15:59:00 PDT
(In reply to comment #3)
> Gotcha. There's been additional information e.g. for "Revisions Requested"
> since bug #3798 was fixed, in version 2.2.3; are you looking at an older
> version?

Well, lookit that. I was even the requester for that one. Apologies for the dupe!

*** This bug has been marked as a duplicate of bug 3798 ***