We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 5318 - Optional Removal of "Online Submissions" options for journals not using the feature.
Optional Removal of "Online Submissions" options for journals not using the f...
Status: RESOLVED DUPLICATE of bug 4198
Product: OJS
Classification: Unclassified
Component: User Interface
2.3.3
PC Mac OS X 10.3
: P5 enhancement
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-04-16 11:50 PDT by Michael Nason
Modified: 2010-06-25 18:04 PDT (History)
2 users (show)

See Also:
Version Reported In: 2.3.1
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Nason 2010-04-16 11:50:52 PDT
We've got a number of situations where editors aren't currently accepting submissions online (though they may in the future). As it stands in OJS now, even if you've disabled user self-registration as an author, the content for "Online Submissions" remains, including the prompt "Registration and login are required to submit items online and to check the status of current submissions."

We (UNB) propose that a toggle in the "Submissions" section of "Setup" be created that will remove this particular instruction for submissions from the About page for journals that wish to have it removed. 

Submission Checklist and Author Guidelines would remain unchanged, while the About page link to "Online Submissions" and that particular part of the about/submissions page would not be visible. 

Authors who have been registered by the Journal Manager would, of course, still be able to submit content from User Home.

If there's interest in this we have someone here to work on the code.
Comment 1 Michael Nason 2010-05-18 11:17:52 PDT
Actually, the more I look at it, "Submission Checklist" should be removed as well in this situation, since the checklist is specific to online submissions.
Comment 2 Alec Smecher 2010-05-18 11:21:03 PDT
Michael, do you mean the Submission Checklist in the "About" section? I'd say there is a case for this to be potentially visible -- i.e. if you want to provide information to submitters for offline submissions -- and it can already be hidden IIRC by deleting all items from it in Setup.
Comment 3 Michael Nason 2010-05-18 11:37:47 PDT
The issue this journal editor in particular is having is with the sentence below "Submission Checklist" 

"As part of the submission process, authors are required to check off their submission's compliance with all of the following items, and submissions may be returned to authors that do not adhere to these guidelines."

She claims it's "wrong". And I guess if you're not going with an online submission process, it's unlikely that users will have to check that content off or have their submissions returned.

Maybe if there's an "online submissions" toggle, then the offending question could be removed, leaving only the checklist itself?

I just tried deleting all the checklist items in 2.3.1.2 and I still get the "submission checklist" header with that sentence intact.
Comment 4 Alec Smecher 2010-05-18 13:34:34 PDT
I see your point re: the wording of "Online Submissions" etc.; I don't think we can support this well without adding a new checkbox, so I guess a new checkbox is what it'll have to be (probably on the "Submissions" page of journal setup).
Comment 5 Alec Smecher 2010-06-25 18:04:20 PDT

*** This bug has been marked as a duplicate of bug 4198 ***