Bug 5003 - Fix APA citation extraction plugin
Fix APA citation extraction plugin
Status: RESOLVED FIXED
Product: PKP-LIB
Classification: Unclassified
Component: General
2.0
PC Linux
: P5 enhancement
Assigned To: Juan Pablo Alperin
: 3512 4046 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-06 08:46 PST by Alec Smecher
Modified: 2010-04-05 11:34 PDT (History)
5 users (show)

See Also:
Version Reported In:
Also Affects:


Attachments
patch against 2.3.1 CVS (21.32 KB, patch)
2010-01-14 21:06 PST, Juan Pablo Alperin
Details | Diff
patch against pkp-lib CVS (713 bytes, patch)
2010-01-14 21:08 PST, Juan Pablo Alperin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2010-01-06 08:46:47 PST
Citation fixes from John 2010/01/05; /slashes denote italics/

APA format:

Hart, D. (2009). Making a Mockery of Mimicry: Salman Rushdie's /Shame/. /Postcolonial Text, 4/(4). Retrieved January 6, 2010, from http://journals.sfu.ca/pocol/index.php/pct/article/view/968/884

...should be e.g.

Bagchi, Alaknanda. "Conflicting Nationalisms: The Voice of the Subaltern in Mahasweta Devi's Bashai Tudu." /Tulsa Studies in Women's Literature/ 15.1 (1996): 41-50. Print.
Comment 1 Juan Pablo Alperin 2010-01-06 09:05:26 PST
I don't thing it should be . Print. 

Its the online version of the citation that we need.  Probably the same with . Web.
Comment 2 John Willinsky 2010-01-06 10:11:35 PST
Updating of APA and MLA Citation Formats

1. APA
(a) If journal uses DOI and pagination:

Devine, P. G., & Sherman, S. J.  (1992). Intuitive versus rational judgment and the role of stereotyping in the human condition: Kirk or Spock? /Psychological Inquiry/, 3(2), 153-159. doi:10.1207/s15327965pli0302_13 

(b) If journal does not use DOI and pagination:

Hodges, F. M. (2003). The promised planet: Alliances and struggles of the gerontocracy in American television science fiction of the 1960s. /The Aging Male/, 6, 175-182. Retrieved from http://www.informaworld.com/TheAgingMale 

(c) If no pagination:

Hodges, F. M. (2003). The promised planet: Alliances and struggles of the gerontocracy in American television science fiction of the 1960s. /The Aging Male/, 6. Retrieved from http://www.informaworld.com/TheAgingMale 

2. MLA format
(a) With no article pagination (URL's are nor longer required):

Dolby, Nadine. “Research in Youth Culture and Policy: Current Conditions and Future Directions.” /Social Work and Society: The International Online-Only Journal/ 6.2 (2008): n. pag. Web. 20 May 2009. 
[last date is date of access]

(b) With pagination:

Dolby, Nadine. “Research in Youth Culture and Policy: Current Conditions and Future Directions.” /Social Work and Society: The International Online-Only Journal/ 6.2 (2008): 29-35. Web. 20 May 2009.
Comment 3 Juan Pablo Alperin 2010-01-14 20:49:35 PST
*** Bug 4046 has been marked as a duplicate of this bug. ***
Comment 4 Juan Pablo Alperin 2010-01-14 20:59:45 PST
*** Bug 3512 has been marked as a duplicate of this bug. ***
Comment 5 Juan Pablo Alperin 2010-01-14 21:06:18 PST
Created attachment 2883 [details]
patch against 2.3.1 CVS

fixed APA and MLA and fixed no issue number and pagination of turabian.  Have not reviewed formats beyond this.
Comment 6 Juan Pablo Alperin 2010-01-14 21:08:09 PST
Created attachment 2884 [details]
patch against pkp-lib CVS

needed to add 1 localization key (rt.captureCite.web)
Comment 7 Juan Pablo Alperin 2010-01-14 21:08:33 PST
committed patch for OJS and pkp-lib.  Leaving bug open for porting to OCS and OMP
Comment 8 Matthew Crider 2010-04-01 17:35:09 PDT
I've ported the latest changes for APA, MLA, and Turabian citation plugins to OCS, and put it on my own github account:

http://github.com/mcrider/ocs/commit/652f69d142fc284571317c2ce9036dd6a450ec5b

After culling the web for the right way to cite conference papers, this is the best I could come up with, but it may not be 100% correct.

As for as locale changes, APA and Turabian involved using already translated keys, but removing a few words from each key--So I did the translations myself and they should be accurate.  MLA is using a new 'n. pag.' key to signify that a paper has no page numbers--This hasn't been translated in OJS, so I couldn't copy in translations from there.  I'm also not really sure if translations of that key would really be that much different anyway.

In any case, Alec, You might want to review these changes before deciding to put them in the upcoming OCS release.
Comment 9 Alec Smecher 2010-04-02 17:34:07 PDT
Matt, looks OK to me at a glance (you now know more about APA than I do), and the locale file changes almost certainly won't conflict with translation work. Go ahead -- as long as you get all OCS locales that are currently in git.
Comment 10 Matthew Crider 2010-04-05 10:34:46 PDT
Pushed to OCS: http://github.com/pkp/ocs/commit/32ca3012da2e566b91bad30365af8dc7e5044986

I'll leave open for OMP?
Comment 11 Matthew Crider 2010-04-05 11:34:23 PDT
Closing in favor of OMP-specific bug #5287.