Bug 4965 - Add DOI information to export plugins
Add DOI information to export plugins
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Plug-ins
2.3.4
PC Mac OS X 10.3
: P5 normal
Assigned To: PKP Support
: 4565 (view as bug list)
Depends on: 5500
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-17 15:36 PST by James MacGregor
Modified: 2011-09-09 11:45 PDT (History)
4 users (show)

See Also:
Version Reported In: 2.3.0
Also Affects:


Attachments
Patch against OJS 2.3.3-3 (1.46 KB, patch)
2011-01-18 10:50 PST, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2009-12-17 15:36:20 PST
If DOIs are being used, they should be exported/exposed. DOI information should also be added to the following export plugins:

-- Article Import/Export XML plugin; 
-- METS Export plugin; 
-- Pubmed plugin(?);

And should also be added to the following exposure plugins: 

-- Webfeed plugins (Bug 4565);
-- all citation format plugins, if relevant;
-- COInS plugin; 
-- METS and Resolver Gateway plugins(?);
-- all oaiMetadataFormats plugins.

DOI Information is already included in the DOAJ and Crossref (of course) export plugins. 

This is a pretty general bug; if it should be split into multiple reports, please let me know (or go ahead and do so). 

(Courtesy of http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=1567&p=21107#p21107)
Comment 1 Juan Pablo Alperin 2009-12-17 16:06:00 PST
I'll open discussion here on whether we should store DOI's as article metadata.  Recently, someone asked what happens if you change the DOI prefix in the Setup.  Currently, the DOI would be exposed based on whatever is auto-generated on demand.  However, there's an argument to be made that DOI's should be generated ONCE and if the pattern changes, then all the previously exposed DOIs are invalid.
Comment 2 James MacGregor 2009-12-17 20:33:07 PST
(In reply to comment #1)
> I'll open discussion here on whether we should store DOI's as article metadata.
>  Recently, someone asked what happens if you change the DOI prefix in the
> Setup.  Currently, the DOI would be exposed based on whatever is auto-generated
> on demand.  However, there's an argument to be made that DOI's should be
> generated ONCE and if the pattern changes, then all the previously exposed DOIs
> are invalid.

Juan, it makes sense to me that an identifier that should be considered permanent should be created once and associated with that particular record. I don't really see a situation where a journal would change its DOI-generation method, but you never know; if they do, we should ensure that all those previously-generated DOIs should still work as expected (that is, presumably, that they are generated once and stored/associated permanently with the rest of the article metadata).
Comment 3 Alec Smecher 2010-01-07 09:31:26 PST
FYI, U of C's PID plugin will set a good pattern for this. It's simply a matter of generating and storing the DOI when the published_articles entry is created (or perhaps when the articles entry is).
Comment 4 Alec Smecher 2010-04-27 12:34:41 PDT
New action available for upgrades:
<code function="installEmailTemplate" key="SUBSCRIPTION_RENEW_INSTL" locales="en_US,fr_CA" />
Comment 5 Alec Smecher 2010-04-27 12:43:39 PDT
Oops! Wrong entry.
Comment 6 Andrea Marchitelli 2010-05-27 05:52:33 PDT
Hi, I think that is very important to expose DOI via OAI-PMH!
Any news about this improvement?
Andrea
Comment 7 Alec Smecher 2010-06-13 02:05:00 PDT
Added to COinS plugin
http://github.com/pkp/ojs/commit/033c3b5171baee6a9f743867f6823311a01e68a3
Comment 8 Alec Smecher 2010-06-13 02:06:53 PDT
*** Bug 4565 has been marked as a duplicate of this bug. ***
Comment 9 Alec Smecher 2010-06-13 03:22:37 PDT
Remaining to be done:

- Webfeed plugins (Bug 4565);
- all citation format plugins, if relevant;
- METS and Resolver Gateway plugins(?);
- all oaiMetadataFormats plugins
- METS export plugin
- Consider for native import, but this would depend on a change to storage as discussed in comments
Comment 10 Alec Smecher 2010-06-19 02:33:34 PDT
Added DOI to DC OAI.
Comment 11 Andrea Marchitelli 2010-06-27 03:33:52 PDT
Maybe could be useful also add DOI to TOC?
See http://pkp.sfu.ca/bugzilla/show_bug.cgi?id=4194
Comment 12 Alec Smecher 2010-06-28 09:55:44 PDT
Yes, Andrea -- see also bug #5524.
Comment 13 Alec Smecher 2010-08-09 11:19:39 PDT
- Changed DOI storage to persist DOIs, once generated
- Added DOI import to native import/export plugin
- Added DOI lookups to resolver plugin

http://github.com/pkp/ojs/commit/83e83b81b8463d66be1a6f165d562685ccf91922

Deferring for consideration elsewhere:
- OAI metadata plugins other than NLM and DC (which already support DOI)
- Citation plugins (which will be better served by refactoring first)
Comment 14 Alec Smecher 2011-01-18 10:50:59 PST
Created attachment 3412 [details]
Patch against OJS 2.3.3-3

Fixed DOI import.
Comment 15 snowy 2011-01-20 04:00:50 PST
Gives the error: "patch unexpectedly ends in middle of line"

And looking at the code it does seem to end in mid-air.  The last line being:

if ($publishedDate === -1) {
Comment 16 Alec Smecher 2011-01-20 09:37:44 PST
Snowy, that patch is correct; how are you applying it?
Comment 17 Alec Smecher 2011-09-09 11:45:02 PDT
Removed asc/desc cruft
https://github.com/pkp/ojs/commit/939f975f6a44b04bf3d3e5896b58f95eeb906952
Comment 18 Alec Smecher 2011-09-09 11:45:02 PDT
Removed asc/desc cruft
https://github.com/pkp/ojs/commit/ae058a16255afbc9444ec7217de7e2b7ea47d519