Bug 4913 - Director decision options don't properly differentiate between "invite presentation" and "accept submission"
Director decision options don't properly differentiate between "invite presen...
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: General
2.1.3
PC Linux
: P5 enhancement
Assigned To: Alec Smecher
: 4859 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-30 11:47 PST by Alec Smecher
Modified: 2009-12-01 15:39 PST (History)
2 users (show)

See Also:
Version Reported In: 2.1.2
Also Affects:


Attachments
Patch against OCS 2.1.2 (10.18 KB, patch)
2009-12-01 06:57 PST, Alec Smecher
Details | Diff
Patch against OCS pre-2.3 CVS (8.02 KB, patch)
2009-12-01 07:21 PST, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2009-11-30 11:47:24 PST
Director decision options don't properly differentiate between "invite presentation" and "accept submission" (two-stage submission process). This is because the getDirectorDecisionOptions function is called in a static context and tries to use the $this object internally.
Comment 1 Alec Smecher 2009-12-01 06:57:29 PST
Created attachment 2645 [details]
Patch against OCS 2.1.2
Comment 2 Alec Smecher 2009-12-01 07:21:28 PST
Created attachment 2646 [details]
Patch against OCS pre-2.3 CVS
Comment 3 Alec Smecher 2009-12-01 07:21:37 PST
Fixed.
Comment 4 James MacGregor 2009-12-01 15:39:09 PST
*** Bug 4859 has been marked as a duplicate of this bug. ***