Bug 4888 - Feature request: Indicate which review form elements are excluded from message to author
Feature request: Indicate which review form elements are excluded from messag...
Status: RESOLVED FIXED
Product: OCS
Classification: Unclassified
Component: Review
2.3.1
Macintosh Mac OS X 10.3
: P5 enhancement
Assigned To: PKP Support
: 5567 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-19 10:34 PST by W.M.BergmannTiest
Modified: 2010-07-13 08:44 PDT (History)
2 users (show)

See Also:
Version Reported In: 2.1.2
Also Affects:


Attachments
patch against ocs 2.1.2 (6.08 KB, patch)
2009-11-19 10:34 PST, W.M.BergmannTiest
Details | Diff
patch against ocs 2.1.2 (7.99 KB, patch)
2009-11-20 02:51 PST, W.M.BergmannTiest
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description W.M.BergmannTiest 2009-11-19 10:34:12 PST
Created attachment 2608 [details]
patch against ocs 2.1.2

As requested, here is a patch in unified diff form that adds an extrasetting to review form elements. By checking a box, the creator of a review form can indicate which review form elements are not to be included in the message to the author when the director clicks the "Import Peer Review" button. This is useful for confidential comments of the reviewer to the director, or secret recommendations for a Best Paper award.

An extra column is needed in table review_form_elements. This should be added when upgrading from a previous version.
Comment 1 W.M.BergmannTiest 2009-11-20 02:51:34 PST
Created attachment 2611 [details]
patch against ocs 2.1.2
Comment 2 James MacGregor 2009-11-24 16:56:29 PST
Thanks, Wouter! I've scheduled against 2.3.1 as we're in a feature freeze for the upcoming 2.3 release.
Comment 3 Alec Smecher 2010-03-15 11:23:05 PDT
Committed, with one minor change: there was some inconsistency about whether the "enabled" flag indicated that an element would be included or not. I've made it consistent so "1" = included, "0" = not included, including upgrade scripts. Thanks for contributing! Committed to OJS and OCS.
Comment 4 James MacGregor 2010-07-13 08:44:39 PDT
*** Bug 5567 has been marked as a duplicate of this bug. ***