We are moving to Git Issues for bug tracking in future releases. During transition, content will be in both tools. If you'd like to file a new bug, please create an issue.

Bug 4887 - Custom Block plugin lost information
Custom Block plugin lost information
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Plug-ins
2.3.3
All All
: P5 normal
Assigned To: Alec Smecher
: 5243 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-19 07:19 PST by Colin Prince
Modified: 2010-07-27 11:22 PDT (History)
6 users (show)

See Also:
Version Reported In: 2.3.0
Also Affects: OCS 2.3.3, OJS 2.3.3


Attachments
Patch against OJS pre-2.3.2 CVS (1.21 KB, patch)
2010-07-27 11:20 PDT, Alec Smecher
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Prince 2009-11-19 07:19:54 PST
Enabled the Custom Block plugin (in the generic area).

Created a block called Directors, saved.

Went to the Block plugins area to edit the new Directors (Custom Block), added names, saved.

Block was already on the right sidebar, I went to Setup 5.6 and move the Directors block from the right sidebar, to the middle, and then to the left sidebar, saved.

The Directors block appeared as expected on the left sidebar.

Went back to the Custom Block plugin (in the generic area) to create another block called Sponsors, saved.

Noted that there were now two Custom Blocks listed.

Went to the Block plugins area. Noticed the new Sponsors (Custom Block) item. The Directors (Custom Block) had disappeared. Checked home page, sure enough, Directors no longer visible.

Went to Setup 5.6, Directors block nowhere to be seen, but new Sponsors block now in the right sidebar area.

Directors block vanished, as if it were never there. Still listed under Custom Block in the generic area.
Comment 1 Bilal Hussain 2009-11-19 08:08:17 PST
The custom blocks appear to be "remembered".

Followed similar steps and reproduced bug.

However, when I switched the labels of the blocks with one another in the custom block plug-in, my first block block reappeared with all it's content on the right sidebar. Also the state of the custom block (enabled/disabled) is also remembered.

Also, whenever entering Step 5.6, observed the custom block defaulting to the right sidebar.
Comment 2 Andrea Marchitelli 2010-07-09 06:31:52 PDT
It seems to me that if you create a new block, the first one you created desappears.
You can't provide two separated blocks (but in the settings page you should view unlimited blocks)
Comment 3 Alec Smecher 2010-07-27 11:09:31 PDT
*** Bug 5243 has been marked as a duplicate of this bug. ***
Comment 4 Alec Smecher 2010-07-27 11:20:31 PDT
Created attachment 3144 [details]
Patch against OJS pre-2.3.2 CVS

Fixed reference glitch and symbolic name problem in custom blocks.
Comment 5 Alec Smecher 2010-07-27 11:22:05 PDT
Patch also works against OCS pre-2.3.3 CVS and should apply to anything recent in the 2.3.x line of either app.