Bug 4869 - add option to set default review form
add option to set default review form
Status: RESOLVED DUPLICATE of bug 5007
Product: OCS
Classification: Unclassified
Component: Review
To be determined
PC Mac OS X 10.3
: P5 enhancement
Assigned To: PKP Support
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-12 09:52 PST by James MacGregor
Modified: 2010-01-18 09:49 PST (History)
3 users (show)

See Also:
Version Reported In: 2.3.0
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James MacGregor 2009-11-12 09:52:26 PST
The Conference Manager should be able to set the default review form (rather than none/free form review be default). Courtesy of: http://pkp.sfu.ca/support/forum/viewtopic.php?f=13&t=5320&p=20417#p20417
Comment 1 W.M.BergmannTiest 2009-11-13 09:25:36 PST
This would be a great feature. I have "solved" this by inserting the line

TrackDirectorAction::addReviewForm($trackDirectorSubmission, $reviewAssignment->getReviewId(), 1);

at the end of function addReviewer in classes/submission/trackDirector/TrackDirectorAction.inc.php. This adds the first (in my case only) review form to the reviewer. This is not safe code because it is not checked if such a review form exists. A "real" solution would of course be better ;-)
Comment 2 Alec Smecher 2010-01-18 09:49:16 PST

*** This bug has been marked as a duplicate of bug 5007 ***