Bug 4865 - Add public identifier information to articles & issues import/export
Add public identifier information to articles & issues import/export
Status: RESOLVED FIXED
Product: OJS
Classification: Unclassified
Component: Plug-ins
2.4.2
PC Linux
: P5 enhancement
Assigned To: PKP Support
: 6930 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-11-09 03:07 PST by Alec Smecher
Modified: 2013-01-08 12:00 PST (History)
2 users (show)

See Also:
Version Reported In: 2.2.3
Also Affects:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alec Smecher 2009-11-09 03:07:56 PST
Add public identifier information to articles & issues import/export. This would hopefully allow an import to overwrite metadata for articles/issues using the same IDs, to effectively update metadata of existing articles.
Comment 1 James MacGregor 2011-01-17 10:37:49 PST
Hi Alec, 

Has this been partially implemented? There appears to be an id option in the import/export XML DTD, meant specifically to add DOIs, and available for issue and article elements. Also, Comment 13 in Bug 4965 suggests that DOI import has been implemented. 

However, adding id information to those elements doesn't seem to work -- DOIs/public IDs aren't added to the database on import. (See http://pkp.sfu.ca/support/forum/viewtopic.php?f=8&t=7014&p=27209#p27209, and I have also replicated.)

If this should be filed as a separate bug, let me know. But I do think it probably ties in with this report as well.
Comment 2 Alec Smecher 2011-01-18 09:08:55 PST
James, could you email me or upload the test XML you're using? Yes, DOI import/export should be implemented for the native XML format as per bug #4965. However, this entry is for OJS's public identifiers, not specifically DOIs.
Comment 3 Alec Smecher 2011-01-18 10:52:28 PST
The issue described in comment #1 and comment #2 is related to bug #4965 and is fixed in OJS 2.3.3-3 by applying Attachment #3412 [details].
Comment 4 Alec Smecher 2011-10-24 11:16:42 PDT
*** Bug 6930 has been marked as a duplicate of this bug. ***
Comment 5 Alec Smecher 2013-01-07 16:04:29 PST
(This entry looks like it's already been obsolete by the PID refactor, but that refactor appears to forget to include the public ID as that's not managed by a plugin. Have inquired of Bozana about that.)
Comment 6 Alec Smecher 2013-01-08 10:30:02 PST
Fix/complete public_id and article lang attributes on export
https://github.com/pkp/ojs/commit/532e38d34aebfa3e790cd8feedf402c44fe1c6d8
Comment 7 Alec Smecher 2013-01-08 11:57:48 PST
Added also the missing article>locale attribute. The DTD has been expanded so an extended one has been uploaded to the PKP server, with the generated URL changed for new exports too. They should be compatible.

For the time being, imports with clashing IDs will result in error messages. An "overwrite/update on conflict" behavior is too risky for 2.4.2. Filing that at bug #8076.
Comment 8 Alec Smecher 2013-01-08 12:00:03 PST
Add public ID info to native import/export
https://github.com/pkp/ojs/commit/b778abd329cbe835c62622893d77d4316650cbdb
Comment 9 Alec Smecher 2013-01-08 12:00:03 PST
Add public ID info to native import/export
https://github.com/pkp/ojs/commit/026873e91b0a5c006cfa88acfdee50b3a3397788
Comment 10 Alec Smecher 2013-01-08 12:00:03 PST
Fix/complete public_id and article lang attributes on export
https://github.com/pkp/ojs/commit/21c26e1fd8bbe5c3658657883b0f7fdf0953a9a6